  領収書PDF管理システム　[RyosyuPDF]

  領収書PDF管理システム　注意事項

◎　特　徴

    １．会計ソフトがなくてもPDFファィルを読み取り登録・表示する管理が可能です。
    ２．ネットワーク接続することなく、パソコン・スキャナーがあれば管理が可能です。
    ３．パソコンは　Windows 7, 8.1, 10, 11 が動作すればＯＫです。
        （　動作環境 に記述していますので参照ください。）
    ４．PDF変更した場合のログデータを出力し、検索表示が可能です。
    ５．プログラム起動時に、パスワード入力にて、データ入力担当者を限定できます。
      データ入力担当者の記録が可能で、修正履歴で「担当者名」が表示される。
    ６．領収書PDFデータの検索、並び換えがいろいろ出来ます。・・詳しくはPDFの検索のページを参照
        （選択項目は　１．日付の範囲、　２．仕入先名(曖昧検索可能)　３．金額の範囲、大小指定、　４．会社CD）
    ７．ネットからのPDFデータの場合原本データ、及び
      検索用PDFファィルの合計「４種類の」PDFファィル　かつ、９種類のｐｄｆ資料等が登録管理できます。
      その他、予備として２種類のPDFファイルも管理できます。 例えば、請求書PDFも保存可能です。
      Ver.3. から以下の９種類の資料等が保存できます。（項目名称は変更可能）
           1.領収書、2.請求書、3.契約書、4.預金関係、5.見積書、6.注文書、
          7.検収書、8.その他書類Ａ、9.その他書類Ｂ
        その他の機能は　領収書データ　メンテナンスのページを参照
    ８．PDFデータの管理以外に、
      インボイス制度に必要な適格請求発行事業者の「発行番号」の登録が出来ます。
      また、検索機能で集計が出来、消費税集計業務の簡素化が可能となります。
      （１万円未満の仕入れはインボイスを不要 などに対応し、表示・集計が可能　）
      その他の機能は　領収書データ　メンテナンスのページを参照
    ９．インボイスの控除などに対応する検索項目の選択が可能
    １０．消費税の既定値がMax.５件までシステム設定で設定可能です。（今後の税額変更に対する変更）
    １１．プログラム終了時に、管理用DBファィル、及びＰＤＦファィルを圧縮ファイルで５世代管理で保存できる。
        （保存の有無が選択出来る）
    １２．仕入先、得意先のインボイス登録番号で、国税庁番号公表サイトで「インボイス番号検索」が可能です。

まず、「はじめに」から御覧ください。

  「電子帳簿保存法」の　電子保存の義務化に2年の猶予　税制改正大綱　などが記述しています。
領収書PDF管理システム　[RyosyuPDF] : This program is a system that manages PDF files of receipts.
Copyright by [RyosyuPDF] & kanazawa S.Miyakawa, 2022 All right reserved


はじめに、機能

電子帳簿保存法 に対応するため、紙の領収書をpdfファィルとして保存

    ◎2022年1月1日に施行される電子帳簿保存法の改正により、電子取引情報の保存ルールが変わります。
    今までは紙で印刷したものを原本として保管できましたが、2022年1月1日以降は取引情報を原則電子データで、

    かつ電子帳簿保存法の要件に則って保存する必要があります。

  開発の背景

  2022年（令和4年）1月1日に施行された改正電子帳簿保存法について、
国税庁は2021年末、「電子保存の義務化」の猶予が2年間認められる要件について解説を公表しました。
「やむを得ない事情」と「整然とした形式及び明瞭な状態で出力されたものを準備しておく」という2つの条件を満たす必要があります。
詳しい要件を整理しました。

    改正電子帳簿保存法、電子保存の義務化に2年の猶予　税制改正大綱
  猶予が認められるための2つの条件
  電子データによる保存が間に合わない事業者に向けて、国税庁は「令和5年（2023年）12月31日までに行う電子取引については、
保存すべき電子データを書面に出力して保存し、
税務調査等の際に提示又は提出ができるようにしておいていただければ差し支えありません」と猶予を認めています。

  また、以下の４つの改正のポイントの条件が追加になっています。
１．承認制度の廃止。
  ◎３ヶ月前の事前承認が廃止となり、
  電子帳簿保存法に対応した機能を備えている会計システムやスキャナー等が準備でき次第、
  速やかに電子保存が可能です。
２．タイムスタンプ要件の緩和
  ◎スキャニングの受領者の署名が不要。
  ◎電子データの修正・削除したことをログに残せるシステムであれば、「タイムスタンプ付与」が不要
３．検索要件の緩和
  ◎検索要件が「取引年月日・取引先・取引金額」のみに
  ◎国税庁などの要求によって電子データのダウンロードに応じることとする場合は、
    指定範囲や項目を組合せて設定する機能の確保が不要
４．電子取引の電子データ保存義務化
  ◎電子データについては書面で保存することが容認されていましたが、
  令和４年４月１日以降行う電子取引データから書面に出力し保存することがは廃止され、電子保存が義務化。
５．インボイスの控除など
  インボイス制度の改正案について 財務省　から　以下のページに記述
      https://www.mof.go.jp/tax_policy/summary/consumption/invoice/index.html
    中小事業者向け少額取引はインボイス不要って？
    1万円未満の課税仕入れ（経費等）について、インボイスの保存がなくても帳簿の保存のみで仕入税額控除ができるようになります!
    対象になる方２年前（基準期間）の課税売上が1億円以下または１年前の上半期（個人は１～６月）の課税売上が５千万円以下の方
    対象となる期間令和５年10月１日～令和11年９月30日

その他　電子帳簿保存法一問一答　より

  詳しい内容は以下の国税庁のPDF文章を参照ください。

  電子帳簿保存法一問一答 【電子取引関係】　 令和４年６月 国 税 庁
https://www.nta.go.jp/law/joho-zeikaishaku/sonota/jirei/pdf/0021006-031_03.pdf

問32 当社はスキャナ保存制度を利用しており、スキャニングした画像データを管理するための文書管理システムで保有しております。
今回、電子取引により受領したＰＤＦデータについても、この文書管理システムで管理することを検討していますが問題ありますでしょうか。

【回答】
電子取引により授受されたデータの保存に当たって、訂正削除履歴や検索などの機能要件を満たすのであれば、

スキャナ保存と同じ文書管理システムで、電子取引のデータを保存しても問題はありません。
【解説】
電子取引の取引情報に係る電磁的記録の保存に当たっては、真実性や可視性を確保するための要件を満たす必要があります

（【問 14】参照）が、例えばスキャナ保存の要件を備えた文書管理ソフトが電子取引の保存要件も満たしている場合には、
当該文書管理ソフトを利用して、電子取引により授受されたデータを保存することも可能であると考えられます。

問14電子取引の取引情報に係る電磁的記録の保存等を行う場合には、どのような要件を満たさなければならないのでしょうか。
【回答】電子取引の取引情報に係る電磁的記録の保存等に当たっては、真実性や可視性を確保するための要件を満たす必要があります。

（規則２②一イ 、二、⑥六、七、４①）。 なお、詳しくは下記の表をご覧ください。

（【問 15】人事業主です。取引の相手方から電子メールにＰＤＦの請求書が添付されて送付されてきました。
一般的なパソコンを使用しており、プリンタも持っていますが、特別な請求書等保存ソフトは使用していません。
どのように保存しておけばよいですか。 【回答】例えば、以下のような方法で保存すれば要件を満たしていることとなります。
      １．請求書データ（ＰＤＦ）のファイル名に、規則性をもって内容を表示する。
          例） 2022年（令和４年）10月31日に株式会社国税商事から受領した110,000円の請求書
          ⇒「20221031_㈱国税商事_110000」
      ２．「取引の相手先」や「各月」など任意のフォルダに格納して保存する。
      ３．【問28】に記載の規程を作成し備え付ける。
        問28 回答
        規則第４条第１項第４号に規定する「正当な理由がない訂正及び削除の防止に関する事務
        処理の規程」は、当該規程によって電子取引の取引情報に係る電磁的記録の真実性を確保す
        る観点から必要な措置として要件とされたものです。
        この規程については、どこまで整備すればデータ改ざん等の不正を防ぐことができるのか
        について、事業規模等を踏まえて個々に検討する必要がありますが、必要となる事項を定め
        た規程としては、例えば、次のようなものが考えられます。
          なお、規程に沿った運用を行うに当たっては、業務ソフトに内蔵されたワークフロー機能
        で運用することとしても差し支えありません。
◎　スキャナ保存関係のパンフレット（PDF/569KB）　・・・　（令和６年１月１日からの取扱いに関するもの）
    国税関係書類の保存義務者の方
        以下のアドレスにて国税庁のpdf を表示できます。
    https://www.nta.go.jp/law/joho-zeikaishaku/sonota/jirei/tokusetsu/pdf/0023006-085_03.pdf

領収書PDF管理システム　[RyosyuPDF]　の　機能一覧

    １．作成された　PDFファィルは自社のコンピュータで保存され、外部にもれが発生しないので完全に安心・安全です。
    ２．領収書の「作成日付」「仕入先名」「金額」で検索出来、いつでも　一発検索で　指定のブラウザで表示できます。
      検索キーは、領収書の「作成日付」「仕入先名」「金額」で、「仕入先名」は一文字の検索、また、複数の文字検索も可能。
    ３．「作成日付」「仕入先名」「金額」の情報は会計システム情報の仕訳帳データからデータを作成するツールを提供。
      会計システムは「.「MJSかんたん！青色申告」、「弥生会計」のExcel(2003)を利用可能。
    ４．インボイスの控除などに対応する検索項目の選択が可能

                                ●　 電磁的記録による保存は、次の3種類があります。

    １．.紙での領収書・・スキャナーで読み取り　領収書の「作成日付」「仕入先名」「金額」で保存します。
    ２．メールでの領収書・・ファイルをPDFファィルで出力し、領収書の「作成日付」「仕入先名」「金額」で保存します。
    ３．ネットでPDFファィルで領収書・・ファイルをPDFファィルで出力し、領収書の「作成日付」「仕入先名」「金額」で保存します。
詳しくは、「動作環境」「制限事項」を御覧ください。

●電子帳簿保存法とは
国税庁によると、電子帳簿保存法とは、税法により、紙での保存が義務づけられている帳簿書類について、
一定の要件を満たせば、電磁的記録（電子データ）による保存を可能とすることなどを定めた法律です。

  各税法で原則として紙での保存が義務づけられている帳簿書類について一定の要件を満たした上で電子データによる保存を可能とすること、および電子的に授受した取引情報の保存義務等を定めた法律です。
    電子帳簿保存法上、電磁的記録による保存は、大きく3種類に区分されています。
    １．電子帳簿等保存（電子的に作成した帳簿・書類をデータのまま保存）
    ２．スキャナ保存（紙で受領・作成した書類を画像データで保存）
    ３．電子取引（電子的に授受した取引情報をデータで保存）


test2領収書PDF管理システム [RyosyuPDF]

  動作環境

システム 環境 | システムに必要な条件 | 推奨する環境
●稼働OS | Microsoft Windows 10 32bit版 / 64bit 版 Microsoft Windows 11 64bit 版 ＊１ 条件有り （Microsoft Windows 7 32bit版 / 64bit 版 ） | Windows10 32/64
●Webブラウザー | Google Chrome Windows Microsoft Internet Explorer 11.0 32bit版 Microsoft Edge（Chromium版） ただし、ＰＤＦファイルが表示可能なもの |
●スキヤナー | Canon製 Inkjet Multifunction Printer ex. Canon TS6000 serie 、Canon TS8130 series XPS など | 動作確認 済
その他のスキャナー | ●「EPSON」プリンター 「EPSON」のよくある質問より引用 https://faq2.epson.jp/web/Detail.aspx?id=3133 | 未検証機器 操作は可能な様です
●ＰＤＦ作成ソフト | 各種 いろいろ また、Canon My Imaage Garden は画像スキャニング後、 直ちに、PDFファイル出力が可能。・・・推奨する機能 (メニューのスキャニングを選択し、ドライバーを選ぶと 帳票のスキャニングが可能です。) | 検証済 内容 Windows10 PDFソフトが無くても ブラウザには表示可能
●領収書PDF管理システム 開発言語 | Visual Basic 6.0 32bit system |
    ＊１；　Windows11 において、Toolberボタンに不具合有り　＝＝＞ Ver.３にてサイズ変更で対応済
ハードウエア 環境 | システムに必要な条件 | 推奨する環境
●ＣＰＵ | ペンティアム ５００ＭＨｚ以上 | Intel(R) Core(TM) Ｉ３以上
●ハードディスク | ４GBバイト以上の空き容量 | ５０GB以上の空き
●メモリ | ４ＧＢ以上 | ８ＧＢ以上
●ディスプレイ | 1024×768ドット以上の解像度 ・Ｈｉｇｈ－Ｃｏｌｏｒ（６５５３６色）以上 | 1920*108 （1366 * 7680） ・Ｈｉｇｈ－Ｃｏｌｏｒ
●プリンター スキヤナー | PDF作成可能なもの Canon製 Inkjet Multifunction Printer EPSON PDF File読み取りが可能なPrinter | Canon製; 使用実績あり
推奨動作環境 快適にお使いいただくためには推奨する動作環境をお勧めいたします。
    ◎　領収書ＰＤＦ保存システム　の　概　要
画面 機能 | 画面一覧 | その他
●データ入力 | ◎分類登録による「９種類」のｐｄｆ書類の保存 ＊２ ◎領収書-処理 １．領収書 登録、変更、削除 ２．領収書 検索 ３．領収書 検索・集計 ＊1 ４．領収書 検索（分類用） ＊２ ◎発行・領収書-処理 １．発行・領収書 登録、変更、削除 ２．発行・領収書 検索 ３．発行・領収書 検索・集計 ＊1 ４．発行・領収書 検索（分類用） ＊２ ＊1；Ver.2.0.0よりサポート ＊２；Ver.3.0.0よりサポート | ◎領収書、発行・領収書 の登録では「領収書」の ＰＤＦファィルでの保存が可能。 また、ＰＤＦファィルのクリックで 「領収書」のＰＤＦファィルの表示が出来ます。 ◎検索機能では、 「日付」「得意先 Or 仕入先」「金額」「会社、事業所」などの 検索キーで、検索が可能です。 （ 得意先 Or 仕入先 ではあいまい検索が可能 ） あいまい検索とは ： 指定した検索キーワードを「含む」データを探す検索
●データ移行・変換 | ◎弥生会計 仕訳 Excel-2003 形式(Ver.5以降) ◎「MJSかんたん！青色申告」の仕訳帳 Excel(2003) |
●マスターメンテナンス | ◎会社（事業所） マスタメンテ ◎仕入先 マスタメンテ ◎得意先 マスタメンテ ◎担当者 マスタメンテ・・ パスワード設定 | 注意事項： 会社（事業所）は設定願います。 他のマスタの登録は不要ですが、 常に使用する場合は入力が簡略出来ます。
●システム 操作 | ◎システム設定 ◎データーベースファイル(DB) 最適化 | システム設定で、ホルダの変更が可能になり、 又、ＤＢの容量オーバー、検索性能の改善に有効化となります。
●メンテナンス モード | ◎データ入力時のログ情報出力 ◎データ移行・変換時のログ情報出力 | 出力 有無の設定が可能 既定値は、「有」 となります。
●印刷機能 | ◎画面のイメージを印刷画面の表示 & 印刷指定 ◎検索の表での[Excel]への出力 又、Text形式も可能 |
●ヘルプ | ◎各画面から [Ｆ１] にてヘルプを表示 |


  制限事項


領収書PDF管理システム [RyosyuM]

  システムの使用規定

領収書PDF管理システム　[RyosyuM] : This program is a system that manages PDF files of receipts.
Copyright by [RyosyuM] & kanazawa S.Miyakawa, 2022 All right reserved


  ｲﾝｽﾄｰﾙ/ｱﾝｲﾝｽﾄｰﾙ


  インストール

１．インストールの方法－１
  ①インストールファイル.
  起動方法
  1. クリックしてインストール用ファイル（RyosyuPDFinstXXX.EXE）をパソコンに保存します。
    （ＸＸＸ　はバージョンよって異なります。）
  2. 保存したインストール用ファイル（RyosyuPDFinstXXX.EXE）をダブルクリックして実行します。＊１
  3. プログラム「RyosyuPDFinst220.EXE」を管理者モードで実行すると、インストールの説明が表示され、
    「ＯＫ」で２種類の方法からの 　「新規インストール」、「バージョンアップ」の
    選択画面が表示されます。　どちらかの方法を選択し、処理を継続します。
  4. インストーラが再開すると、指示にしたがって継続します。
＊１；　バージョン 2.2.0から　「新規インストール」、「バージョンアップ」の２種類になりました。
        一度インストール済のユーザは「バージョンアップ」を選択ください。
  ②インストール操作
  1. 領収書PDF管理システムのインストール画面が開きます。
  2. スクロールして文章をお読みいただき、インストールを続ける場合は「次へ」をクリックします。
    （注意事項：パスワードの記述が文章の最後有ります。）
  3. インストール先を指定する画面が開きます。
    通常はそのまま「次へ」をクリックします。
    初期インストール先は　以下の様に表示され、Windows １１、1０、８、７、と異なります。
    規定値は「C:\RyosyuPDF\」です。
    Windows ７、８、１０、１１、の場合は絶対に「C:\Program Files\RyosyuPDF\」に変更しない様に願います。動作保障いたしません。
    推奨するホルダの設定； システムドライブ(Cドライブ)以外のホルダを指定願います。
      （オッズテータは随時保存しますので、毎週増大していきます。）
  4. コンポーネントの選択について
      新規インストール時には規定値で実行します。バージョンアップ　及び、
    再インストールの時に各チェツクを設定します。

２．コンポーネントの選択について
処 理 内 容 | 11,10,8 規定値 | 7 規定値 | 説 明
１．プログラムの上書き | レ | レ | プログラムを上書きしない場合は「チェツク」を外します。 「チェツク」の時は最新プログラムに上書きされます。
２．SYSTEMホルダの上書き | レ | レ | SYSTEMホルダに書き込むファイルを上書きしない場合は「チェツク」を外します。 「チェツク」の時は最新データに上書きされます。
３．データ変換データベースの上書き |  |  | 「\DATA\OPmstJV.mdb」を強制的に上書きする場合にチェックします。 通常は「\DATA\OPmstJV.mdb」が古い、無い場合（新規）に出力されます。
４．スタートに「プログラムグループ」を表示 | レ | レ | 出力しない場合に「チェツク」を外します。 特にバージョンアップ、再インストールの時に有効です。
５．ディスクトップに「アイコン」を表示 |  |  | 表示したいときに「チェツク」します。インストール後からも表示は可能です。
６．以下のカスタムコントロール、ＤＬＬ登録処理をする。 | レ | レ | バージョンアップインストール時に「チェツク」を外すと、短時間で処理できます。
７． １．[ＶＢ６用] の登録時に 置換しない。 | レ |  | ・ＶＢ６用専用のコントロール、ＤＬＬです。 1１、1０、８、７、の場合に登録エラーになる場合がありますので、「チェツク」有りにすると、 各モジュールがすでにインストール済みの場合は登録は行いません。 プログラム起動時に「OCX、DLLが古い」などのエラーメッセージが表示された場合、 ※※ 原因として、すでに同一のOCX、DLLがインストール済み、かつ古い場合に表示されます。 古いのOCX、DLLで動作中のプログラムに影響が無いかを確認し、 このチェツクをはずして再インストール願います。※※
８． ２．[RyosyuPDF用] の 登録時に置換しない。 |  |  | RyosyuPDF 専用のコントロール、ＤＬＬです。 「チェツク」はＶＢ６用と同様です。 チェックが無い場合は、古いOCX、DLLは置換されます。 プログラム起動時に「OCX、DLLが古い」などのエラーメッセージが表示された場合、 ※※ ＶＢ６と同様、このチェツクをはずして再インストール願います。※※ チェツクを外した「サンプルの画面」を見る
３．インストールの方法－２
  ③　インストール操作－２
  5. インストール完了をお知らせする画面が開きます。
    インストール進行中の画面。
  6. システム設定画面が開きます。
    内容を確認して、「更新」ボタンを押します。　「終了」で画面が閉じます。
    ※注意　EXCEL APP の設定について　「システム設定」を確認ください。
    また、システム設定の表示の画面で「更新」を押さないと正常に起動しない場合があります。、
    必ず、「更新」ボタンを押しましょう。
  7. ヘルプ画面が開きます。内容を確認し、画面を閉じます。
  8. 領収書PDF インストール　最終処理の画面が表示されます。
    プログラム起動時のパスワード「５桁の数字」が表示されます。
    パスワードを控え　保存ください。　＊１
    「最終処理を実行する」    をクリックするとインストールは終了します。

    注意事項　「最終処理　中止」では　プログラム起動時は出来なくなります。
  9. インストールが完了しましたので、完了をクリックしてください。

＊１： パスワードの変更もインストール後、可能です。

  パスワードを忘れた場合、再インストールで初期パスワードの設定表示されます。


  アンインストール

    注意事項：　アンインストールすると　インストール時の情報、ファイルは削除されます。

１．アンインストールの方法
  1. コントロールパネル」＞「プログラムのアンインストール」をクリックします。
  2. 「RyosyuPDF」を選択し、アンインストールと変更を選択又は、ダブルクリックします。
    アンインストールオプション　のアンインストール　の画面が表示します。
  3. .「次へ」を押して進みます。
    後は画面の指示に従って処理を継続して、終了します。


  システム　ご利用の前に


  日付と時刻の設定

  この機能はパソコンのWindowsの機能を使用します。詳しくはWindowsを参考願います。

  1.タスクバーの「時計」を左クリック
  2.日付と時刻の調整　をクリック
  3.現在時刻の変更
    自動で設定、手動で設定、又は　今すぐ同期　を選択し、時間の設定を行います。


  Ｗｉｎｄｏｗｓの画面設定

  この機能はパソコンのWindowsの機能を使用します。詳しくはWindowsを参考願います。

  1.Windows の設定画面を開きシステムを選択
  2.ディスプレイ　を選択する。
  3.画面の配置を選択後、画面を選び「拡大縮小とレイアウト」で
    「テキスト、アプリ、その他の項目のサイズを変更する」で
    100% などのサイズを選択する。
    また、ディスプレイの解像度を選択する。


  クイックガイド

■初めて使用の方
■データ変換ＤＢファィルの最適化
■ＤＢファィルデータ整理
■システム設定
■バックアップ


  初めて使用の方

１．システムのインストール |
２．PDFファイルの読取機のセット | 動作環境のスキャナーで記述の推奨機での設定について Canon My Imaage Gardenの設定について記述します。 ①「Canon Quick Menu」を起動し、「My Imaage Garden」を起動すると プリンター情報の取込後に、スキャンを選択します。 ②スキャン設定情報にてスキュン情報をPDF出力するために、 以下の設定を行います。 「スキャン設定」-「ScanGear」で １．.「データ形式」をPDF ２．「PDF圧縮」を「高圧縮」を選択 以上の設定で、読み取り画像ファイルは「PDF」となります。
３．PDFファイルの読取 | 動作環境のスキャナーで記述の推奨機での設定について Canon My Imaage Gardenの設定について記述します。 「メニュー」の「ドライバー」をクリックし、画像をスキャンします。 (詳しくはソフトのヘルプを参照ください。) 他のソフトを利用の場合は「画像をスキャン」ファイルをPDF出力します。
４．領収書PDF管理システムの起動 | インストールで作成された [RyosyuM３.exe - ショートカット]をクリックします。
５．マスターの登録 必須 | ①会社Mメンテナンス にて「会社」又は「事業所」を登録する。 ②仕入先Mメンテナンスにて「仕入先」を登録する。 自由登録 ③得意先Mメンテナンスにて「得意先」を登録する。 自由登録 ＜＝＝確認する
６．パスワードの登録 | メニュー・ツールバー＆パスワード入力 担当者管理 有りの場合、 「担当者コード」、「担当者パスワード」の設定が可能です。 登録画面を確認＜＝＝確認する
７．領収書データ メンテナンス | 領収書データ メンテナンスを起動し、領収書PDFを登録する
８．Acrobat Reader DC インストール済の場合 | 「専用画面」の選択でAcrobat Readerの表示が可能となります。 また、規定のアプリで 名前「.pdf」を「Google Chrome」に設定すると 「ブラウザ表示」の選択で 「Google Chrome」で表示
９．ＰＤＦ表示ツールの登録 最適な 方法を選択で出来ます | １．未登録の時は、「Microsoft Edge」 のＰＤＦ機能で表示されます。 ２．規定のアプリで 名前「.pdf」を「Google Chrome」に設定すると 「Google Chrome」で表示 ３．ＰＤＦ表示ツールの登録の場合、 「専用画面」で表示が可能です。

●「EPSON」プリンターの場合の　ＰＤＦファイル読み取りについて
     「EPSON」のよくある質問より引用　　https://faq2.epson.jp/web/Detail.aspx?id=3133


  データ変換ＤＢファィルの最適化


  ＤＢファィルデータ整理


  システム設定

  「ｲﾝﾎﾞｲｽ　売上・控除設定」は　次ページの索引項目で参照下さい。
Ver.2.5.2 「消費税率」をメンテナンスする様に変更。消費税率変更に対する改定
            次ページの索引項目で参照下さい。
１．システム設定 の 画面構成
◎画面サンプルはホルダ等の変更が可能で、 変更して運用している内容です。Ｃ： Ｄ： Ｅ： などのドラスブを作成した後の参考例です。 既定値は「C:\RyosyuPDF」となります。
２．選択処理項目の概要
① 初期値 | システムの既定値の情報をセットします。
② 終了 | 画面を閉じます。
③ 更新 | 画面の項目を更新します。
④ 保存戻し | 最初に表示した項目の内容を表示します。
⑤ ？ ヘルプ | ヘルプの表示は 「F1」キーにて表示されます。
３．ホルダ設定 ・・・ 「参照」ボタンを押すと以下の項目が選択出来、ホルダがセットされます。
①プログラム | いろいろなプログラムが起動されるホルダです。既定値はインストーラで設定されます。
②システムホルダ | システム関係のファィルが保存されています。 (例：ヘルプファイル)
③ログ保存ホルダ | 登録情報のメンテナンスで保存するファィル。 Ver.1.1.0からは\DATA\MKpdfLog.mdb
④仕訳DATAホルダ | 仕訳データからデータ移行する際のデータホルダ
⑤PDFホルダ | 領収書PDFファイルを保存するホルダ
⑥Backupホルダ | インストールで古いファイルを保存するホルダ
⑦WORKホルダ | 作業用ホルダ 消されても良いファィルを保存
⑧変換DBホルダ | 変換用DBがセットされるホルダ
⑨Data保存用ホルダ |
４．ファイル設定 ・・・ 「参照」ボタンを押すと以下のファィル項目が選択出来、ファィルがセットされます。 「最適」ボタンは メインプログラムの未起動の時に操作できます。
①変換用DB名称 | 変換DBホルダのファィルを指定します。既定値：「MKpdf.mdb」
②変換用DB Log | 変換DBホルダのLogファィルを指定します。既定値：「MKpdfLog.mdb」
③変換用DB 分類 | 変換DBホルダの分類ファィルを指定します。既定値：「MKpdfBun.mdb」
④Excel APP | Excel プログラムのあるホルダ プログラム初期起動で自動でセットされますが、 複数の表計算プログラムがある場合は、起動する「表計算プログラム」をセット願います。 例； Excell2003の場合、「C:\Program Files\Microsoft Office\OFFICE11\EXCEL.EXE」


  システム設定(ｲﾝﾎﾞｲｽ情報)

  Ver.3.1.0 国税庁番号公表サイトでの「インボイス番号検索」アドレスの項目を追加しました。
  Ver.2.5.2 「消費税率」をメンテナンスする様に変更。消費税率変更に対する改定
１．システム設定 の 画面構成
◎現在のバージョンは 左側画面の「売上・控除設定」項目で表示
２．選択処理項目の概要 以下のボタンは「ﾎﾙﾀﾞ& File」の画面の内容と同時に変更されます。
① 初期値 | システムの既定値の情報をセットします
② 終了 | 画面を閉じます。
③ 更新 | 画面の項目を更新します。
④ 保存戻し | 最初に表示した項目の内容を表示します。
⑤ ？ ヘルプ | ヘルプの表示は 「F1」キーにて表示されます。
３．インボイス 売上・控除設定 ・・・ 「:検索集計」の際に 参照して 表示され集計の際に使用されます。
①売上高金額 以下 | 売上高の控除対象金額をセットする。
②控除対象仕入金額 | インボイス不要とする仕入対象金額をセットする。
③その他 予備 | 現在は 予備項目

  詳しくは　2022.12.17新聞記事を参照下さい。
    ◎売上高１億円以下の事業者を対象に、１万円未満の仕入れはインボイスを不要とし、
      事務負担を緩和する。インボイスを保存しておかなくても帳簿があれば
      仕入にかかった消費税の控除を受けられるようにする。

４．「消費税率」をメンテナンスする様に変更。消費税率変更に対する改定
従って各種画面の「消費税率」はシステム設定の設定順で表示します。
        例えば、[13.0][10.0][8.0][0.0][0.0]の様に設定します。
        規定値は[10.0][8.0][0.0][0.0][0.0]となります。

５．各画面の「国税庁検索」ボタンで表示する既定値のアドレスを設定します。
    Ver.3.1.0 からの追加された機能です。
インボイス登録番号の設定画面で「国税庁検索」ボタンをクリックした時の、初期値を以下の２つから選択します。
    １．「国税庁法人番号公表サイト」
        初期値；　https://www.houjin-bangou.nta.go.jp
    ２．「国税庁インボイス制度適格請求書発行事業者公表サイト」
        初期値；　https://www.invoice-kohyo.nta.go.jp
  また、　「国税庁　番号公表サイト」が変更された時は、ユーザにて変更し、更新します。


  システム設定(分類項目設定)

  Ver.3.0.0 「分類毎のＰＤＦファイル登録」　機能のため、分類項目設定　の項目を追加しました。
１．システム設定 の 画面構成
◎Ver.3.0.0 て゜は、左側画面の「分類設定」項目で表示
２．選択処理項目の概要 以下のボタンは「ﾎﾙﾀﾞ& File」の画面の内容と同時に変更されます。
① 初期値 | システムの既定値の情報をセットします
② 終了 | 画面を閉じます。
③ 更新 | 画面の項目を更新します。
④ 保存戻し | 最初に表示した項目の内容を表示します。
⑤ ？ ヘルプ | ヘルプの表示は 「F1」キーにて表示されます。


バックアップ

  ●Ver.3.1.0 :「ＤＢバックアップを年度別指定を追加しました。」
  ◎　メニューのバックアップ*1を起動すると表示されます。
      また、プログラム終了でバックアップが起動します。
      バックアップの選択は自由です。ユーザにて対応ください。
    *1:　「メニュー」－「ファイル」－「その他」－「バックアップ」で起動できます。
  １．バックアップ　操作・・・D/B のバックアップ初期画面

  ◎データＤＢ全期間、の設定する場合にチェツクします。
  ◎年の指定でバックアップのFrom To をセットします。
    年間、全期間、前年のチェツクで期間がセットされます。
  ◎「バックアップ処理　開始」でデータの保存が開始されます。
注意事項；
    １．Ver.3.1.0 :「ＤＢバックアップを年度別指定を追加
    ２．DATAホルダの他のホルダにmdbファイルと同一名のファイルが有ると、
        エラーとなります。==>他のホルダのmdbファイルを削除してから保存ください。
  １．バックアップ　操作・・・D/B のバックアップ

  ◎バックアップファイル名の表示。
  ◎前回バッサクアップの年月日、時間を表示
      (なしの時は、ALL 0 で表示)

  ◎「いいえ」の選択でキャンセルされます。　毎回バックアップは不要ですが、
    定期的に保存願います。
  ２．バックアップ　操作・・・PDFファィルのバックアップ

  ◎バックアップPDFファイル名の表示。
  ◎前回バッサクアップの年月日、時間を表示
      (なしの時は、ALL 0 で表示)

  ◎「いいえ」の選択でキャンセルされます。
  ３．バックアップの結果表示

  バックアップファイルの名称：
  ◎D/B、PDFのバックアップの結果が表示されます。
    なお、バックアップの履歴は　No.1～ No5まで存在する。
No.1 => No.2 => No.3 => No.4 => No5 => 削除 の様にして 名前を変更している。
[ 1 ] が一番新しく、大きい番号ほど古く、[ 5 ]が一番古い。

  なお、ファィルの復旧に備え、USBデイスクなどに保存ファイルをバックアップしてください。


  操作方法


メニュー・ツールバー 構成

  メニュー・ツールバー　構成　＆　パスワード入力

１．入力担当者　＆　パスワード　の入力
  「担当者」の作業制限の為に、「パスワード」による入力画面が表示されます。

    １．インストール時に表示された「パスワード」を入力し
        「入力OK」をクリックします。

    ２．担当者管理　有りの場合、以下の項目入力となります
    「担当者コード」、「担当者パスワード」の入力項目が表示され、
    「担当者コード」、「担当者パスワード」の入力後に、「ＳＥＴ」を押します。
    正しい入力の場合、担当者名が表示されます。

    ３．「パスワード」が正しい場合、「パスワードＯＫ」が表示され、
    引き続き「会社コード」の入力となります。　－－＞ 「ＯＫ」 を押します。

  パスワードが正しい場合のみメインプログラムの「各種ボタン」が起動できます。
担当者管理が有る場合

担当者管理が　無い場合、管理者のパスワードのみ

  2．領収書PDF管理システムの画面構成
    ◎タイトルバー　・・　領収書PDF管理System[RyosyuPDF]　と　バージョンが表示されます。
    ◎メニューバー　・・　メニューバーをクリックして選択すると、
        操作を実行できます。
    ◎ツールバー　・・　領収書PDF管理Systemで一番多く使う操作のボタンが表示されています。
    ◎メッセージバー　・・　システムで設定されている「ホルダ」「ファイル」情報が表示されています。
  「担当者」の作業制限の為に、「パスワード」による入力画面が表示されます。
  インストール時に表示された「パスワード」を入力し「入力OK」をクリックします。
  注意事項： 異なるパスワードの場合は「入力エラー」が表示されます。
                「キャンセル」の場合、正しく動作しません。
                例えば、いろいろなボタンをクリックしても　画面表示はされません。

  最初にメンテナンスする　「会社名・事業所」　をセットします。


メニュー・ツールバー　詳細

１．領収書PDF管理システムの画面構成
メニューバー の説明
1.ファィル | １．.マスタメンテ・・・ 会社・事業所、仕入先、得意先、担当者・・管理者のみ変更可能 ２．その他・・・ システム設定、ＤＢ最適化、ＰＤＦ登録・更新日 修復、 バックアップ（ALL 年度別） ３．起動時のパスワード入力 ・・ 入力担当者の変更に使用 ４．終 了
２．領収書・処理 | １．領収書 登録・変更 ２．発行・領収書 登録・変更 ３．領収書 検索・問合せ ４．発行・領収書書 検索・問合せ ５．領収書 集計・検索 ６．発行・領収書 集計・検索 ７．領収書 集計・検索（分類ｐｄｆ） ８．発行・領収書 集計・検索（分類ｐｄｆ）
３．データ移行処理 ・・Excel | １．仕分けﾃﾞｰﾀ ==> 領収書 ２．仕分けﾃﾞｰﾀ ==> 発行領収書
４．ウインドウ | １．現在の画面状態を保存 ２．すべての画面を閉じる ３．子画面のみ・・・ 最大化で表示、並べて表示、重ねて表示、横に並べて表示、ｱｲｺﾝの整列
５．ｵﾌﾟｼｮﾝ・設定 | １．画面表示位置・・・クリアー (左上)、 設 定、設定取込み ２．ログ出力モード ３．ログ表示
６．ヘルプ | 表示中の画面にて Ｆ１ボタンを押す
メニュー ボタン の 説 明
１．ＥＸＩＴ | プログラムを終了する。 終了する際に、バックアップ（ALL)が起動します。
２．領収書メンテ | 領収書メンテナンス画面が起動します。
３．領収 検索 | 領収書検索画面 が起動します。 右ボタンで 検索用のサブメニューが表示されます。
４．仕分->請求 | 仕分けﾃﾞｰﾀ ==> 領収書への移行画面が表示されます。
５．発行領収書メンテ | 発行領収書メンテナンス画面が起動します。
６．発行領収書検索 | 発行領収書検索画面 が起動します。 右ボタンで 検索用のサブメニューが表示されます。
７．仕分->発行請求 | 仕分けﾃﾞｰﾀ ==> 発行領収書への移行画面が表示されます。
８．印刷 | 表示中の画面の印刷用の画面が開き、印刷が可能となります。
その他の表示 | 以下のボタンで右ボタンクリックで表示される １．領収・検索 ボタン ・・・ 領収書・検索、 領収書・集計&検索 ２．発行領収書・検索 ボタン ・・・ 発行領収書・検索、 発行領収書・集計&検索
入力項目 の説明 ・・ メンテナンスする 会社コードを 作業の前にセットします。
１．会社'コード | 登録済の会社'コードを入力
２．会社'コード | 会社コードから名称を表示
３．会社・検索 ボタン | 登録済の会社コードからセットする時に ボタンを押し、表示一覧から選択します。
注意事項：担当者マスタメンテナンス　は　単独起動となります。管理者用のパスワードが必要です。
      インストールホルダの「system\RtantoM.exe」を起動します。


  ﾃﾞｰﾀの取込

  ◎　プログラムの起動直後、担当入力者の作業制限の為に、
      パスワードによる入力画面が表示されます。
  ◎　データ取込には、「会社コード」の入力が必要です。
■仕分データの取り込み
■領収書データ　メンテナンス
■発行領収書データ　メンテナンス
■領収書PDFファイルの取込み


  仕分データの取り込み

◎ Ver.3.2.0　データの追加・更新モードを選択可能とした。
    更新ミスを避けるため、初期値は「追加・更新」無しとなっています。

◎ 以下の会計ソフトからの作成された仕訳データのEXCELファィルから取込、
    領収書データを作成する。
  １．「弥生会計」仕訳 Excel-2003 形式(Ver.5以降)＊１
  ２．「MJSかんたん！青色申告」の仕訳帳　Excel(2003) ＊２

改修履歴
  ◎Ver.2.5.2　弥生会計の消費税が反映される様に改定しました。
    ただし税区分の名称にご注意ください。＊１
●Ver.3.0.0 : １．借方金額 を設定し、貸方金額が無い場合は 借方金額を用いる。
                ２．発行請求データからの変換で「MJSかんたん」「弥生会計」の判断が一部で漏れがあり機能追加。
１．仕訳データの取り込み 画面構成
２．項目の概要 |
① ロード (EXCEL) | 仕訳出力したファイル「Shiwake\Shiwake*.xls」を読み取る
② 仕訳更新 | 読み取った 仕訳出力したファイル で更新する。
③ 追加更新モード (Ver.3.2.0 より) | 画面の選択項目をチェツクされた条件で仕分け更新する。 （既定値は無し） 選択条件 ①追加 有、②更新 有
④ 更新会社 (必須)項目 | 更新対象の会社コードを入力する。 この入力で明細データに会社コードがセットされます。
⑤ 更新日付 | 日付の範囲を入力 From To で設定 日付の範囲内のデータのみ更新対象です。
⑥ 日付ワンタッチ ボタン | 更新日付をワンタッチで設定 今日 今月 年間 全期間 前年 選択した内容で自動で更新日付がセットされます。 更新日付は変更も可能です。
仕訳出力したファイルの領収書情報出力のための 仕訳帳入力 方法について

  ここからが「入力方法」のポイント
１．対象システム
  「MJSかんたん！青色申告」の仕訳帳　Excel(2003)で出力する
  「弥生会計」の仕訳 Excel-2003 形式(Ver.5以降)で出力する
２．操作方法
  １．仕訳帳入力での注意方法
    摘要欄に仕入れ先　等を入力します。・・・「S=」「T=」のデータのみ更新対象となります。
    方法は「S=」の次に「仕入れ先名」を記述し、最後に半角「/」をセット
    「/」の後に商品名などの備考内容をセットします。
    ◎インターネットでのネット取引の場合は半角「/NET」を記述します。
      この場合、領収書データの「発行区分」に電子の「1」がセットされます
    例えば、「　S=仕入れ先名称/商品名称/　」又は
            「　S=仕入れ先名称/商品名称/NET　」の様にセット
      また、複数の税額有りの場合、
    例えば「/」の後に「内訳有り」又は「内訳％」などわかりやすく設定し、
    データ変換後税書くの設定で複数税率の設定を行います。

    売上げの時は「T=」の次に「得意先名」を記述し、最後に半角「/」をセット
    ◎インターネットでのネット取引の場合は半角「/NET」を記述します。
      (注意事項:「MJSかんたん！青色申告」の摘要欄は全角２１文字となっているので、
      項目オーバーの際はExcel出力後、摘要欄の修正を行います。)
    例えば、「　T=仕入れ先名称/商品名称/NET　」の様にセット

  ２．仕訳帳　Excelで出力する  注意：弥生会計の場合はテキストファィルとなります ＊１
    出力前に項目を追加する。
    空き項目欄に「会社CD」を追加し、その列に「会社CD」を記述する。

  ３．変更するExcelファイルを　Excel(2003)で出力
    ファイル名はホルダ「Shiwake」に
    「Shiwake」を付けます。他はわかりやすい名称を付けます。
    例えば　「ShiwakeG12021Book.xls」の様にする。

  ４．RyosyuM.exe ----領収書管理　を起動する
    1.領収書変換処理を表示する。
    2.Excelファイルを選択する。
    3.変換する「会社CD」を入力する。
    4.変換するボタンを押す。
      領収書テーブル仕訳帳データが追加されます。

  ５．領収書処理を起動する。
    検索ボタンで明細が表示されます。
    1.「pdf」ファィルの項目をクリックすると
    「pdf」ファィルが表示されます。
    2.未登録の場合は表示されませんので、
      スキャナーで領収書を取り込み、「pdf」ファィルを付けて保存します。
      なお、ホルダ名は　「\PDF\2021\B01」の場所とします。
      例えば「20210110_XXXX_00001000.pdf」の場合は以下の様になります。
      「\PDF\2021\B01」のホルダとします。
＊１：「弥生会計」仕訳 Excel-2003 形式(Ver.5以降)　について
    現在は「テキスト書き出し（エクスポート）」の出力が有効な様です。
    EXCEL での出力は MS-Office のいろいろな制限が有る様なので、使用出来ませんてした。
    弥生会計の操作ガイドの「テキスト書き出し（エクスポート）」をに記述内容　を参照ください。

    1-1.出力ポイントは、データのエクスポートの欄にある様に、「弥生インポート形式」で出力
    1-2.力ファィルはテキスト(.txt)で出力されますので出力ファィルを「EXCEL」で開きます。
    1-3.この時の「EXCEL」指定は、
      1.データファイル形式は　「カンマやタブ・・・・」を選択　次へ
      2.区切り文字の選択は　「タブ」「カンマ」をチェツクし、　次へ
      3.完了　をクリック
    1-4.「.xls」で名前を付けて出力します。
      「EXCEL」で正しく表示されたのを確認し、
      「shiwake」を付けてユニークな名称で「.xls」で出力します。
      例えば「shiwake202201.xls」の様に出力します。
      なお、「.xls」とは　Excel 2003形式です。
    Ver.2.5.2 での修正内容・・・以下の消費税区分のみ対応します。
      [課対仕入別] [課対仕入込] [課対仕入内] [課対仕入外]
      [課税売上別] [課税売上込] [課税売上内] [課税売上外]
     注意事項；「仕訳更新」ボタンでの消費税更新はデータ作成済データに更新しますので
    新規データの場合は2度「仕訳更新」ボタンをクリックする事になります。

＊２：「MJSかんたん！青色申告」の仕訳帳　Excel(2003)について
    弥生会計　に比べて大変かんたんです。

    1-1.仕訳帳を標示し、期間を選択後、「EXCEL」出力すると、EXCELが起動します。
    1-2.「EXCEL」で正しく表示されたのを確認し、
      「shiwake」を付けてユニークな名称で「.xls」で出力します。
      なお、「.xls」とは　Excel 2003形式です。


領収書PDFファイルの取込み

  領収書データ　メンテナンス　　　Ver.3 はここで表示

  ●Ver.2.1.0 : 発行区分=１電子の時、PDF Copyの１(４つのうち一番上)を設定すると、
                          元ファイル等１にも　PDFファイル元データがセットさ、保存ホルダにもファィルがコピーされる。
  ●Ver.2.2.0 :検索 ＋Ctr　で　PDF ファイル名のバックカラーが黄色で表示
  ●Ver.2.3.4 :「領収書　登録・変更　単独」の画面を「領収書　登録・変更」と同等な機能としました。
  ●Ver.2.3.4 :「金額」の上にカーソルを移動すると、「金額」「税率」「税額」を表示します。ただし、「税額」が有る場合のみ
  ◎ＰＤＦ表示画面項目の設定　⑪「PDFの表示」についての考察・・注釈　を参考ください。
１．領収書データ メンテナンス の 画面構成 (サンプル画面はVer.0.9.0の場合)
２．項目の概要
① 処理区分 | １：登録 ２：修正 ３：削除 登録、修正、削除 を押すと、処理区分にセットされます。 終了 を押すと画面を閉じます。
② 領収年月日 |
③ 仕入先コード |
④ 領収金額 |
⑤ 明細表示 | ②～④までの内容で該当する領収書が有れば、仕入先名からの項目を表示する。
⑥ 明細更新 | 登録、または変更された項目内容で データ更新する。ただし、①の処理区分に従います。
⑦ 中止 | 中止の場合 何もせず、①処理区分に戻ります。
⑧ 会社コード | 会社コード または 事業所 を入力・・・(メイン画面の会社コード入力が表示されます。) 変更も可能です。 直接「会社コード」を入力 又は「会社検索」で入力できます。
⑨ 会社検索 | 会社の一覧が表示され、選択すると会社名がセットされる。 会社を選択後に画面を閉じます。
⑩ 仕入先検索 | 仕入先の一覧が表示され、選択すると仕入先名がセットされる。
⑪ PDFの表示 | PDFファィルの表示画面の選択。 ブラウザ指定で標準ブラウザに表示する。(注釈 を参照)
⑫ 手前に表示 | チェツクが有ると 表示画面を常に手前に表示します。
⑬ SET | PDFファイル名をセットします。・・・ 「日付＋仕入先名＋金額．PDF」
⑭ PDF表示 | セットされたPDFファイル名を表示します。 未セットの場合は表示なしのメッセージを表示
⑮ PDF表示 | 元ファイル名のPDFファイル名を表示します。 未セットの場合は表示なしのメッセージを表示
⑯ PDF COPY | Ver.2.1.0 より 改定 １． スキャナーで読み込まれたPDFファィルをセットされたPDFファイル名に変更し規定ホルダにCOPYします。 ２．ネットがら取得したPDFファィルを規定ホルダにCOPYします。かつ元ファイル名欄にPDFファイル名を表示します。 Ver.2.1.0 より 改定； 発行区分=１電子の時、PDF Copyの１(４つのうち一番上)を設定すると、 元ファイル等１にも PDFファイル元データがセットさ、保存ホルダにもファィルがコピーされる。 Ver.2.0.0 からの元ファイル等１２３ の入力欄 注意事項： 元ファイル等１２３ の名称のな長さは「半角１００文字」以内となります。 ＰＤＦファィルの他、いろいろなファイルを登録可能となりました。 （Ver.3.0.0より） ファイル選択の時に「全ﾌｧｲﾙを選択し、いろいろなファィルを選択できます。」
⑰ PDF規定ホルダ | PDFファィルを保存する規定ホルダ名が表示されています。 Ver.3 から、表示のみとし、変更不可となっています。 （変更はシステム設定で行います）
Ａ ～ Ａ＋ | 仕入先〒 から 税率 までは 任意な情報項目です。 ( ⑬～⑰まで、Ｂ～Ｂ＋までは除きます) 請求書YMD ・・ 請求書の有る場合、請求書の日付をセットする 借方科目、貸方科目・・仕訳データ取込から移行したときに自動でセットされた内容が表示されます。 税率、税額、インボイス登録番号・・[T] + 13桁の登録番号・・ 無い場合は未記入 発行区分 ・・・ １桁目１：請求書 ２桁目：領収書 ０：紙 １：電子 ２：メール ８：その他 ファイル区分 ・・・ ０; pdf のみ・・・現在の仕様 発行区分
Ｂ ～ Ｂ＋ | 入力項目の変更された場合の日付が表示されます。 (登録日、修正日、PDF登録日、PDF修正日、)
Ｃ 検索 | 選択項目で領収書の内容を表示します。 表示された明細の各種操作について・・・以下の画面、表を参照ください。
検索 ＋Ctr | PDf ファィルの設定の無い場合、PDF ファイル名のバックカラーが黄色で表示されます。 注意： 明細表示中に、表示
Ｄ 選択項目のセット | 検索された明細を選択し、この「ボタン」で 上段の項目が表示されます。
検索明細MAX件数 | 既定値は３００件 変更は可能です。次回ヘ継続されます。
３．検索内容の 画面構成
４．検索内容の概要
検索項目 | 選択項目は １．日付の範囲、 ２．仕入先名(曖昧検索可能) ３．金額、 ４．会社CD(事業所も含む) 「スペース」または「０」の場合は全項目対象・・ 日付は選択ボタンでのセットが可能、 金額はALL、大、小、根等しい から選択 会社コードは自動でメイン画面のコードが表示されますが、変更、又はスペースも可能です。
表示項目 | 日付、仕入先CD、仕入先名、金額、発行区分、ファイル区分、PDFファイル名、会社CD、会社名、概要、 登録日、修正日、PDF登録日、PDF修正日、請求書YMD
PDFファイル名 | 黒色表示： PDF登録日 Space, or ALL 0 ・・・ PDF未登録 赤色表示： PDF修正日 有り ・・・ PDF修正登録あり 青色表示： PDF修正日 なし ・・・ PDF登録済
その他の機能 | 各項目の表題のクリックで 昇順・降順で並び替え、PDFファイル名のクリックでPDFファイルを画面表示
Ver.2.2.0 :「検索＋Ctr」又は「検索＋右クリック」で PDF ファイル名のバックカラーが黄色で表示
「検索」ボタン を 右クリックで バックカラー黄色で表示 | ・・ 未割付のＰＤＦファィルが明確に確認できる様にする為に作成しました。
Ver.2.3.4 :「金額」の上にカーソルを移動すると、「金額」「税率」「税額」を表示します。ただし、「税額」が有る場合のみ

注釈
◎ＰＤＦ表示画面項目の設定 ⑪「PDFの表示」についての考察・・Windows10 の場合 |  |
１．PDF表示ツールが未登録 標準表示 | Microsoft Edge のＰＤＦ機能で表示されますので 選択を「ブラウザ表示」とする | 「Microsoft Edge」のＰＤＦ機能で表示
２．PDF表示ツールが未登録 ブラウザ がChrom登録有り ［推 奨］ | OS設定の規定のアプリの設定で「Webブラウザー」を 「Microsoft Edge」から「Google Chrome」に変更します。 また、「ファィルの種類ごとに規定のアプリを選ぶ」で 名前「.pdf」で「Google Chrome」を設定します。 | 「Google Chrome」のＰＤＦ機能で表示 ただし、名前「.pdf」で「Google Chrome」が 未設定の場合は「Microsoft Edge」で表示される
３．PDF表示ツールが登録されている 選択を画面表示とする | 専用画面の表示が可能 また、選択を「画面表示」で表示しない場合は 選択を「ブラウザ表示」とする | PDF表示ツール で機能が変わりますので PDF表示ツール の設定で確認のこと

  ◎ＰＤＦ表示画面項目の設定　⑪「PDFの表示」についての考察・・Windows10 の場合
    １．PDF表示ツールが未登録　の時、選択が「ブラウザ表示」のみとなります。
    ２．Acrobat Reader DC　の登録済の時、「画面表示」の選択で、「Acrobat Reader DC」での表示となります。
        この時、以下の設定で表示します。
        １）「Webブラウザー」を 「Google Chrome」の時、
          「ファィルの種類ごとに規定のアプリを選ぶ」で　名前「.pdf」で「Google Chrome」を設定します。
        ２）「Webブラウザー」を 「Microsoft Edge」の時、
          「ファィルの種類ごとに規定のアプリを選ぶ」で　名前「.pdf」で「Microsoft Edge」を設定します。

    ３．その他のPDFツールの時、選択が「ブラウザ表示」で、指定するPDFツールの画面が表示されます。
        （「画面表示」の選択では、２ステップの表示になります。
          ただし、パソコンによって色々変化が有る様です。）


領収書データ メンテナンス Ver.３

領収書データ　メンテナンス　Ver.３　　Ver.2 までの詳しい改定はここで表示

  ●Ver.3.2.0 :消費税複数明細 入力のリリース
  ●Ver.3.1.2 :データ検索画面での検索表示の改良・・pdfファィルの上にマウスをセットすると、割付けた分類用pdfの名称を表示
              ;明細に分類pdfの割付番号を「０」～「８」まで連続で表示。また、項目の上にマウスをセットすると、割付けた分類用pdfの名称を表示
  ●Ver.3.1.0 :不具合の改定　領収書、発行領収書の分類登録の有る明細の表示後に新規登録すると、分類登録が無いのに間違って有る様に表示される減少の改定。
  ●Ver.3.1.0 : 国税庁番号公表サイトでの「インボイス番号検索」を追加しました。
  ●Ver.3.0.0 : 「分類」毎にｐｄｆを登録する機能を追加しました。
      1.領収書、2.請求書、3.契約書、4.預金関係、5.見積書、6.注文書、7.検収書、8.その他書類Ａ、9.その他書類Ｂ
    また、画面サイズの調整のため　項目設定位置が変更になっています。
    注意事項：　Ver.2まで作成されたデータの場合、「領収書」のボタンに着色はされません。
                    ただし、Ver.3 で一度更新すると、着色されます。
    注意事項２：　PDF規定ホルダについて・・・　Ver.3 から、表示のみとし、変更不可となっています。　（変更はシステム設定で行います）

１．領収書データ メンテナンス の 画面構成 (サンプル画面は Ver.3.0.0 の場合)
２．Ver.３ で追加された機能
 | ◎以下の分類のＰＤＦファィルが登録出来ます。 1.領収書、2.請求書、3.契約書、4.預金関係、5.見積書、 6.注文書、7.検収書、8.その他書類Ａ、9.その他書類Ｂ １．操作方法 [PDF Copy] の下の項目名称を選択し、[PDF Copy] ボタンのクリックで 登録が開始されます。 ２．ｐｄｆファィルの選択する画面が開き「ｐｄｆファィル」を選択します。 詳しくは、通常の[PDF Copy] と同様です。 ３．選択済みの場合、ボタンが淡赤色に着色されます。 淡赤色に着色されたボタンをクリックすると、登録済の「ＰＤＦファィル」が表示されます。 注意事項： 必ず「明細 更 新」 ボタンをクリックし、最新のデータとして登録します。 忘れた場合は データ更新はされませんので、再登録が必要となります。
３．登録内容の表示について
 | 「領収・検索」の右ボタンメニューで、「領収・検索／分類」にて一覧表として 検索表示できます。 領収書、発行領収書の検索 分類検索 のページを参照下さい。
４．分類名称の登録について
 | システム設定で変更が可能です。が できるだけ既定値を推奨します。 システム設定(分類項目設定) のページを参照下さい。
５．Ver.３.1.0 で追加された機能
 | Ver.3.1.0から追加の機能 ・・ 国税庁検索 ボタン を追加 「ＯＫ」で「国税庁検索」サイトを表示します。
 | 検索 ボタン； Ver.3.1.0 から追加の機能です。 「インボイス登録番号」 が設定されている場合、 ボタンのクリックで「国税庁検索」サイトを表示し、 「登録番号」欄にインボイスＮｏを左ボタンで貼り付けが可能です。 また、「国税庁検索」サイトの設定はシステム設定で選択又は変更可能です。
５．Ver.３.２.0 で追加された機能
 | 税率の下の「％」ボタンをクリックすると、 左の画面 「複数税率SET」が表示されます。 ① 指定の税率を選び、区分を選択し、税額を入力します。 ② 税額の合計 が合計欄に表示されます。 ③ 終了時に合計欄の金額と税額欄の金額が異なる場合は、 確認メッセージが表示され、「はい」で更新されます。 この消費税複数明細は「明細更新」ボタンのクリックで、 データ更新されます。 ④ 複数税率SETされた場合、税率表示は「内訳」と表示されます。 注意； この入力は消費税複数の不要な場合は設定不要です。 税率の表示はシステム設定の「消費税率」で設定された内容で 表示します。


  発行領収書データ　メンテナンス

◎　領収書データ　メンテナンス　と同様な操作方法です。
  領収書データ　メンテナンスのページを参照ください。
●Ver.3.1.0 : 国税庁番号公表サイトでの「インボイス番号検索」を追加しました。　Ver.3.1.0　を見る　　Ver.2の内容を見る
●Ver.2.3.4 :．「発行領収書　登録・変更　単独」の画面を「発行領収書　登録・変更」と同等な機能としました。
●Ver.2.3.4 :「金額」の上にカーソルを移動すると、「金額」「税率」「税額」を表示します。ただし、「税額」が有る場合のみ


領収書データ メンテナンス

  領収書PDFファイルの取込み

  ◎PDFファィルの作成はパソコンによっていろいろ有ると思います。
    ここでは推奨する方法として以下に、動作環境に記述しています。
  Canon 「スキヤナー」の「Canon My Imaage Garden」で行います。

１．Canon 「スキヤナー」の「Canon My Imaage Garden」で記述
  １．「Canon My Imaage Garden」の起動画面

  「スキャナー」を選択する。
  ２．スキャナーの「スキャン設定」画面

    「ScanGear」をクリックし
    データ形式を　「PDF」　に設定
    PDF圧縮タテプを「高圧縮」　に設定
        「OK」 をクリック

  ３．スキャン　の開始

    「ドライバー」をクリックし、
    「プレビュー」をクリック、
    「出力解像度」を200dpi
    「出力サイズ」をフリーサイズ

    「サムネイル」の表示を切り替える。
    「スキャン」ボタンを押す。
  ４．PDFファィルの取込
  ５．PDFファィルの保存

    １．　「保存」ボタンをクリックする。

    ２．「データ形式」をPDF を確認し、
      「保存」をクリックする。

  ◎複数のPDFファイルを一つのPDFとする時は、
    複数複数のPDFを選択し、保存します。
  ６．PDFファィルの割付、取込

  領収書　メンテナンス　で
  「PDF Copy」ボタンをクリックし、
    「５．PDFファィルの保存」で出力したファイルを
    選択します。
  ７．PDFファィルの確認、表示

    「pdf 表示」ボタンをクリックします。
  表示画面に「PDFファイル」が表示されます。

  表示画面には
  １．ブラウザ画面
  ２．画面表示が有ります。

  パソコンのよって正しく表示される画面を選択下さい。

  画面サンプルでは PDF表示ソフトとして
  「Sdobe Systems X1」 の場合の表示です。
また、WIndows10,11では
  「Adobe Acrobat DC」で動作しています。


  領収書PDFの検索

■領収書、発行領収書　の検索・・・領収書　及び　発行領収書の検索を行えます。
■領収書、発行領収書　の　検索・集計・・・領収書　及び　発行領収書　の　検索を行い、仕入先名の集計が行えます。


領収書、PDFの検索－１

  領収書、発行領収書の検索

  ●Ver.2.2.0 PDF File の無い場合、表示機能追加
      :「検索」下選択 下三角のクリック　で　PDF ファイル名のバックカラーが黄色で表示
  ●Ver.2.3.4 検索機能で、明細の金額の上にマウスを移動すると、
        [取引先（得意先）]、[金額]，[税率]、[税額]、[インボイス登録番号]を表示する。
表示サンプルは Ver.2.1.0 のものです。
１．ボタン などの 説明
１．終了 | 画面を閉じます。また。最大明細件数を保存します。
２．印 刷 | 画面のイメージを印刷する画面を表示し、印刷も可能です。 また、下三角 のクリックで 以下の項目で表示、出力が可能です。 １．EXCELを表示 ２．画面表示・・Print ３．クリップボードに出力
３．検 索 | 「2.検索内容」の選択、入力項目を基にして、検索します。 明細最大行数まで表示します。 明細数が明細最大行数を超えた場合はメッセージにて注意表示します。
４．検 索 下選択 下三角 のクリック | 「PDF File無 黄着色」 にて PDf ファィルの設定の無い場合 PDF ファイル名のバックカラーが黄色表示。
５．選択項目セット | 選択した明細行の内容を検索項目のうち、「入力項目」にセットします。 Ver.2.2.0より マウス右クリックで「仕入先」「領収金額」の表示をクリアーする
２．検索内容の概要
検索項目 | 選択項目は １．日付の範囲、 ２．仕入先名(曖昧検索可能) ３．金額、 ４．会社CD(事業所も含む) 「スペース」または「０」の場合は全項目対象・・ 日付は選択ボタンでのセットが可能、 金額はALL、大、小、根等しい から選択 Ver.2.4.0 からの選択項目追加： インボイスのみ表示用チェツクボタン「赤枠」を追加・・・ インボイス登録番号有りのみ表示
表示項目 | 日付、仕入先CD、仕入先名、金額、発行区分、ファイル区分、PDFファイル名、会社CD、会社名、概要、 登録日、修正日、PDF登録日、PDF修正日、請求書YMD など 税率は[10.0%] で表示 金額ゼロは未表示
その他の機能 | 各項目の表題のクリックで 昇順・降順で並び替え、PDFファイル名のクリックでPDFファイルを画面表示 明細行のクリックで「仕入先」「領収金額」の表示機能を削除。 Ver.2.2.0より 理由・・・ 再検索の時に「仕入先」「領収金額」のロンテナンスが発生する為
３．その他 項目 の 説明
１．手前に表示 | チェツクが有ると 表示画面を常に手前に表示します。
２．フォントサイズ | 明細一覧表の文字サイズを変更できます。
３．明細最大行数 | 検索表示時の 明細の最大表示件数
４．PDF表示画面 | PDFファィルの表示画面の選択。 １．ブラウザ表示 ・・・ ブラウザ指定で標準ブラウザに表示する。 ２．画面表示 ・・・ PDF表示ツールがインストールされている時は 専用画面表示となります。


領収書、発行領収書の検索 分類検索

  ●Ver.3.2.0 検索機能で、消費税が有る場合、マウスの移動で複数明細の表示を提供
  ●Ver.3.0.0 各資料の「分類」毎にｐｄｆを登録する機能を追加で、検索画面を追加しました。
  ●Ver.3.0.2「set」ボタンのクリックで各項目表示変更で、画面表示も変更します。
１．ボタン などの 説明 ・・・ 他の操作ボタンは Ver.２ までの機能を参照下さい。
ＰＤＦファィルの 有無表示 | [全項目]～[他書類Ｂ]までのボタンで検索内容の明細のｐｄｆ表示有無を選択します。 [全項目] ；全項目を表示します。 [領収書]～[他書類Ｂ] ；表示有無をセットします。 [ set ] ； 各項目の表示有無を保存し、次回からの表示 既定値とします。 Ver.3.0.2から「set」ボタンのクリックで各項目表示変更で、画面表示も変更します。 その後、変更後、再度 検索します。 各ボタンで表示項目を選択後に、「検索」で各分類書類の項目表示が可能になります。
ＰＤＦファイルの表示 | 登録されているＰＤＦファィル名を表示します。 また、各分類のｐｄｆが登録されている場合は「◎」印で表示されます。 ファイル名で「ｐｄｆ名」をクリックすると ＰＤＦファィルが表示されます。 また、「F2」「F3」「F4」及び 「請求書」～「他書類Ｂ」の「◎」をクリックすると 「ｐｄｆファイル」が表示されます。 「請求書」～「他書類Ｂ」で、ｐｄｆファィルの発生区分が紙以外の場合、 検索用PDFファイル、ネットPDFファイル の選択が出来ます。 選択後に、ｐｄｆファイルが表示されます。
選択項目セット | 選択した明細行の内容を検索項目のうち、「入力項目」にセットします。 マウス右クリックで「仕入先」「領収金額」の表示をクリアーする
インボイス設定有無指定 | インボイスのみ表示用チェツクボタン「赤枠」をチェツクすると、インボイス登録番号有りのみ表示


領収書、発行領収書 の 集計・検索

  領収書、発行領収書　の　検索・集計

  ●Ver.3.2.0 検索機能で、消費税が有る場合、マウスの移動で複数明細の表示を提供
  ●Ver.2.3.4 検索機能で、明細の金額の上にマウスを移動すると、
    １．　[取引先（得意先）]、[金額]，[税率]、[税額]、[インボイス登録番号]を表示する。
    ２．集計機能・・[仕入先の行] での小計から[並び替えた行]での小計を表示する。
１．ボタンの説明
１．終了 | 画面を閉じます。また。最大明細件数を保存します。
２．印 刷 | 画面のイメージを印刷する画面を表示し、印刷も可能です。 また、以下の項目で表示、出力が可能です。 １．EXCELを表示 ２．画面表示・・Print ３．クリップボードに出力
３．検 索 | 選択項目で検索します。 明細最大行数まで表示します。 明細数が明細最大行数を超えた場合はメッセージにて注意表示します。
４．集 計 | 表示項目で並び替え後で、仕入先名毎で集計します。 集計ボタンを押すと金額の「小計」「明細合計」を表示します。 Ver.2.3.4; 「仕入先の行」での小計から「並び替えた行」での小計を表示する。
５．選択SET | 選択したした明細行データ を 検索項目にセットします。
２．検索内容の概要
検索項目 | 選択項目は １．日付の範囲、 ２．仕入先名(曖昧検索可能) ３．領収金額、 ４．会社CD(事業所も含む) 「スペース」または「０」の場合は全項目対象・・ 日付は選択ボタンでのセットが可能、 金額はALL、大、小、根等しい から選択 Ver.2.4.0 からの選択項目追加： インボイスのみ表示用チェツクボタン「赤枠」を追加・・・ インボイス登録番号有りのみ表示 Ver.2.5.0 から選択項目追加 「システム設定(ｲﾝﾎﾞｲｽ情報)」で設定する内容を参照して検索表示します。 １：売上高金額 以下・・ メモ項目 ２：控除対象仕入金額 ・・ この金額で「以上・以下」を判断 －－－－－－－－－－－－－－－－－－－－－－－－－－ インボイスの控除などに対応する 表示項目の選択を検索の下項目に追加 １：「ｲﾝﾎﾞｲｽ対象 有り」・・ １万円以上の仕入れの集計表示 ２：「ｲﾝﾎﾞｲｽ対象 無し」・・ １万円未満の仕入れの集計表示 ３：「免税事業者 集計」・・ 免税事業者のみ検索表示します Ver.2.5.2 から選択項目追加 「税率」を選択項目に追加・・・スペース、ALL の選択は全件表示、％選択は指定税率のみ表示 a) 税率０で 税額がある場合、内税で表示 b) 税率が有り、税額が「０」の場合は、選択項目「ERR」で表示される・・・エラーデータ対応
表示項目 | 日付、仕入先CD、仕入先名、金額、発行区分、ファイル区分、PDFファイル名、会社CD、会社名、概要、 登録日、修正日、PDF登録日、PDF修正日、請求書YMD など 税率は[10.0%] で表示 金額ゼロは未表示
その他の機能 | 各項目の表題のクリックで 昇順・降順で並び替え、PDFファイル名のクリックでPDFファイルを画面表示
３．その他 項目 の 説明
１．手前に表示 | チェツクが有ると 表示画面を常に手前に表示します。
２．フォントサイズ | 明細一覧表の文字サイズを変更できます。
３．明細最大行数 | 検索表示時の 明細の最大表示件数
４．PDF表示画面 | PDFファィルの表示画面の選択。 １．ブラウザ表示 ・・・ ブラウザ指定で標準ブラウザに表示する。 ２．画面表示 ・・・ PDF表示ツールがインストールされている時は 専用画面表示となります。


  修正ログ表示


  ログ表示

  ●Ver.3.0.0 各資料の「分類」毎にｐｄｆを登録する機能を追加で、領収書等の資料毎の「ログ表示検索画面」を追加しました。
      起動はメニューのオプション設定「ログ表示」、「ログ表示 Ver.３」で起動します。
  ●Ver.３の　「ログ表示検索画面」

担当者ログイン　検索画面

１．ボタン などの 説明
１．処理ボタン |
２．検索設定内容 等 | などの検索設定内容は Ver.２ を参照下さい。
３．．領収書等の 明細表示内容 | 「領収書、仕入先、金額」のｐｄｆファィル情報毎に並び替えて表示されます。 また、修正内容は「修正日付」「修正時間」「修正区分」で以下の内容を表示します。 １．変更内容 ２．ファイル名、 ３．会社名 ４．概要 分類ファィルが有る場合は 分類ｐｄｆの設定済の順に[1]で表示 ５．借方、貸方 勘定科目 ６．登録日付、修正日付、ｐｄｆ登録日付、ｐｄ修正日付 ７．担当者、 ８．税率、税額、 ９．インボイス番号 詳しくは画面サンプルを御覧ください。
４．担当者ログイン 情報内容 | 担当者ログイン 情報を表示します。 ただし、担当者ログイン情報の表示は、管理者のパスワードが必要です。 表示内容は「日付」「時間」「担当者コード」「名称」「かな」「Pass」の内容を表示します。 表示内容の設定； ログイン日付 １．From To ２． 担当者コード・・・空白は全件 注意事項； SYSTEM ホルダにPass管理ＤＢ[MKPass.mdb] が無い場合は表示出来ません
  ●Ver.２までの　「ログ表示検索画面」

  １．ボタン などの　説明

  ボタンの操作に関して、「領収書、発行領収書の検索」を参照ください。


  マスタメンテナンス

   Ver.２にて「検索ボタン」を押すと「明細一覧」に表示されます。
■会社Mメンテナンス
■仕入先Mメンテナンス
■得意先Mメンテナンス
■担当者Ｍメンテナンス


  会社Mメンテナンス

    Ver.2.5.0 操作性を改良し、新規作成ました。
１．システム設定 の 画面構成
検索後の更新での サンプル画面です。 ＊：必須入力項目 処理選択の後に表示されるボタン
２．操作ボタンの内容
① 終了 | 画面を閉じ、プログラム終了します。
② 登録 | 会社コードの入力になります。 コードがすでに存在する場合は登録済メッゼジが有ります。 また、「実行」「取消」ボタンが表示されます。(以下同様) 注意： （Max.データ件数=100件）
③ 修正 | 会社コードの入力になります。
④ 削除 |
⑤ 検索 | 「会社コード」の時に「実行」を押すと、明細が表示されます。 また、「会社コード」なしで「実行」を押すと、一覧表に最初のデータから表示されます。 注意事項：「検索」ボタンの横の数値は検索ボタンをクリックした時の データ件数を表示しています。
⑥ 開始Key | 「スペース」：最初のキー項目の表示 「キー」データ： このキーから表示 赤線より下の一覧表に各会社データが表示されます。
⑦ 処理区分へ | 各項目はクリアーされ、処理区分入力へ
⑧ 処理「実行」 | 「処理「実行」」ボタンで、入力内容が更新されます。 登録： 入力内容が登録されます。 修正： 入力内容が更新されます。 削除： 会社コード の内容が削除されます。 各処理の後確認メッセージが表示され、会社コード入力へ戻ります。 （各項目はクリアーされます。）
⑧ 取消 | 「取消」で、入力内容が取り消され、会社コード入力へ戻ります。 （キー項目は クリアーされ、他の項目は維持されます。）
３．各項目 入力 |
①会社コード 半角４文字 | 「登録」の時は、コードがすでに存在する場合は登録済メッゼジが有ります。 「修正」「削除」の時は、登録済として内容が表示されます。 コードがすでに存在しない場合は、「該当データが有りません」を表示。
②会社名 | 会社名 を入力します 必須 入力 願います。
③フリガナ | フリガナ を入力します 必須 入力 願います。
④その他 の項目 | 郵便番号～ファクシミリ までは自由記載
⑤インボイスＮｏ． | 会社にインボイスＮｏ．がある場合にメモとして記入します。
４．一覧表の処理内容
①一覧明細行のクリック | 各列の内容をクリックすると「各項目」の表示項目にデータがセットされ、 修正モードになり、項目の訂正＆更新処理が可能になります。 処理「実行」ボタンで更新できます。
    以下のサンプルは、Ver.2.4.0 までの内容です。
   Ver.２にて「検索ボタン」を押すと「明細一覧」に表示されます。

１．システム設定 の 画面構成
初期 表示画面です。 ＊：必須入力項目 処理選択の後に表示されるボタン
２．操作ボタンの内容
① 終了 | 画面を閉じ、プログラム終了します。
② 登録 | 会社コードの入力になります。 コードがすでに存在する場合は登録済メッゼジが有ります。 また、「実行」「取消」ボタンが表示されます。(以下同様)
③ 修正 | 会社コードの入力になります。
④ 削除 |
⑤ 参照 | 「会社コード」の時に「実行」を押すと、明細が表示されます。 また、「会社コード」なしで「実行」を押すと、最初のデータが表示されます。 ボタンは ⑥始 ～終 までが表示されます。
⑥ 始 ～終 まで | 「始」：最初のキー項目の表示 「＜」：一つ前のキーが表示 「＜」：一つ前のキーが表示 「終」：最後のキー項目の表示
⑦ 実行 | 「実行」ボタンで、入力内容が登録され、会社コード入力へ戻ります。
⑧ 取消し | 「取消」で、入力内容が取り消され、会社コード入力へ戻ります。 また、「会社コード」未入力で押された場合、は「処理選択」に戻ります。
３．各項目 入力 |
①会社コード 半角４文字 | 「登録」の時は、コードがすでに存在する場合は登録済メッゼジが有ります。 「修正」「削除」の時は、登録済として内容が表示されます。 コードがすでに存在しない場合は、「該当データが有りません」を表示。
②フリガナ | フリガナ を入力します 必須 入力 願います。
③会社名 | 会社名 を入力します 必須 入力 願います。
④その他 の項目 | 部署～ファクシミリ までは自由記載


  仕入先Mメンテナンス

    Ver.3.1.0 国税庁番号公表サイトでの「インボイス番号検索」を追加しました。
    Ver.2.5.0 操作性を改良し、新規作成しました。
１．システム設定 の 画面構成
検索後の更新での サンプル画面です。Ver.2.5.0 ＊：必須入力項目 処理選択の後に表示されるボタン Ver.3.1.0から追加の機能 ・・ 国税庁検索 ボタン を追加 「ＯＫ」で「国税庁検索」サイトを表示します。
２．操作ボタンの内容
① 終了 | 画面を閉じ、プログラム終了します。
② 登録 | 仕入先コードの入力になります。 コードがすでに存在する場合は登録済メッゼジが有ります。 また、「実行」「取消」ボタンが表示されます。(以下同様) 注意： （Max.データ件数= 現在制限なし？）
③ 修正 | 仕入先コードの入力になります。
④ 削除 |
⑤ 検索 | 「仕入先コード」の時に「実行」を押すと、明細が表示されます。 また、「仕入先コード」なしで「実行」を押すと、一覧表に最初のデータから表示されます。 注意事項：「検索」ボタンの横の数値は検索ボタンをクリックした時の データ件数を表示しています。
⑥ 開始Key | 「スペース」：最初のキー項目の表示 「キー」データ： このキーから表示 赤線より下の一覧表に各仕入先データが表示されます。
⑦ 処理区分へ | 各項目はクリアーされ、処理区分入力へ
⑧ 処理「実行」 | 「処理「実行」」ボタンで、入力内容が更新されます。 登録： 入力内容が登録されます。 修正： 入力内容が更新されます。 削除： 仕入先コード の内容が削除されます。 各処理の後確認メッセージが表示され、仕入先コード入力へ戻ります。 （各項目はクリアーされます。）
⑧ 取消 | 「取消」で、入力内容が取り消され、仕入先コード入力へ戻ります。 （キー項目は クリアーされ、他の項目は維持されます。）
３．各項目 入力 |
①会社コード 半角４文字 | 「登録」の時は、コードがすでに存在する場合は登録済メッゼジが有ります。 「修正」「削除」の時は、登録済として内容が表示されます。 コードがすでに存在しない場合は、「該当データが有りません」を表示。
②会社名 | 仕入先名 を入力します 必須 入力 願います。
③フリガナ | フリガナ を入力します 必須 入力 願います。
④その他 の項目 | 郵便番号～ファクシミリ までは自由記載
⑤インボイスＮｏ． | 仕入先にインボイスＮｏ．がある場合にメモとして記入します。
⑥国税庁検索 ボタン | Ver.3.1.0 から追加の機能です。 インボイスＮｏ．が設定されている場合、 ボタンのクリックで「国税庁検索」サイトを表示し、 「登録番号」欄にインボイスＮｏを左ボタンで貼り付けが可能です。 また、「国税庁検索」サイトの設定はシステム設定で選択又は変更可能です。
４．一覧表の処理内容
①一覧明細行のクリック | 各列の内容をクリックすると「各項目」の表示項目にデータがセットされ、 修正モードになり、項目の訂正＆更新処理が可能になります。 処理「実行」ボタンで更新できます。


  得意先Mメンテナンス

    Ver.3.1.0 国税庁番号公表サイトでの「インボイス番号検索」を追加しました。
    Ver.2.5.0 操作性を改良し、新規作成ました。
１．システム設定 の 画面構成
検索後の更新での サンプル画面です。 ＊：必須入力項目 処理選択の後に表示されるボタン Ver.3.1.0から追加の機能 ・・ 国税庁検索 ボタン を追加 「ＯＫ」で「国税庁検索」サイトを表示します。
２．操作ボタンの内容
① 終了 | 画面を閉じ、プログラム終了します。
② 登録 | 得意先コードの入力になります。 コードがすでに存在する場合は登録済メッゼジが有ります。 また、「実行」「取消」ボタンが表示されます。(以下同様) 注意：注意： （Max.データ件数= 現在制限なし？）
③ 修正 | 得意先コードの入力になります。
④ 削除 |
⑤ 検索 | 「得意先コード」の時に「実行」を押すと、明細が表示されます。 また、「得意先コード」なしで「実行」を押すと、一覧表に最初のデータから表示されます。 注意事項：「検索」ボタンの横の数値は検索ボタンをクリックした時の データ件数を表示しています。
⑥ 開始Key | 「スペース」：最初のキー項目の表示 「キー」データ： このキーから表示 赤線より下の一覧表に各得意先データが表示されます。
⑦ 処理区分へ | 各項目はクリアーされ、処理区分入力へ
⑧ 処理「実行」 | 「処理「実行」」ボタンで、入力内容が更新されます。 登録： 入力内容が登録されます。 修正： 入力内容が更新されます。 削除： 会社コード の内容が削除されます。 各処理の後確認メッセージが表示され、得意先コード入力へ戻ります。 （各項目はクリアーされます。）
⑧ 取消 | 「取消」で、入力内容が取り消され、得意先コード入力へ戻ります。 （キー項目は クリアーされ、他の項目は維持されます。）
３．各項目 入力 |
①会社コード 半角４文字 | 「登録」の時は、コードがすでに存在する場合は登録済メッゼジが有ります。 「修正」「削除」の時は、登録済として内容が表示されます。 コードがすでに存在しない場合は、「該当データが有りません」を表示。
②会社名 | 得意先名 を入力します 必須 入力 願います。
③フリガナ | フリガナ を入力します 必須 入力 願います。
④その他 の項目 | 郵便番号～ファクシミリ までは自由記載
⑤インボイスＮｏ． | 得意先にインボイスＮｏ．がある場合に請求書登録の際に表示されます。
⑥国税庁検索 ボタン | Ver.3.1.0 から追加の機能です。 インボイスＮｏ．が設定されている場合、 ボタンのクリックで「国税庁検索」サイトを表示し、 「登録番号」欄にインボイスＮｏを左ボタンで貼り付けが可能です。 また、「国税庁検索」サイトの設定はシステム設定で選択又は変更可能です。
４．一覧表の処理内容
①一覧明細行のクリック | 各列の内容をクリックすると「各項目」の表示項目にデータがセットされ、 修正モードになり、項目の訂正＆更新処理が可能になります。 処理「実行」ボタンで更新できます。


担当者Ｍメンテナンス

  Ver.2.4.0 からリリースされました。
  ●起動の条件・・・管理者でパスワード入力された場合にのみ起動できます。
    （メニューの「ファイル」－「マスタメンテ」－「担当者」をクリックします。）
    プログラムが起動すると、管理者のパスワードの入力になり、
    正しい場合にメンテナンスが可能になります。
    Ver.2.5.0 操作性を改良し、新規作成ました。
１．システム設定 の 画面構成
検索後の更新での サンプル画面です。 ＊：必須入力項目 処理選択の後に表示されるボタン
２．操作ボタンの内容
① 終了 | 画面を閉じ、プログラム終了します。
② 登録 | 担当者コードの入力になります。 コードがすでに存在する場合は登録済メッゼジが有ります。 また、「実行」「取消」ボタンが表示されます。(以下同様) 注意： （Max.データ件数= 現在制限なし？）
③ 修正 | 担当者コードの入力になります。
④ 削除 |
⑤ 検索 | 「担当者コード」の時に「実行」を押すと、明細が表示されます。 また、「担当者コード」なしで「実行」を押すと、一覧表に最初のデータから表示されます。 注意事項：「検索」ボタンの横の数値は検索ボタンをクリックした時の データ件数を表示しています。
⑥ 開始Key | 「スペース」：最初のキー項目の表示 「キー」データ： このキーから表示 赤線より下の一覧表に各会社データが表示されます。
⑦ 処理区分へ | 各項目はクリアーされ、処理区分入力へ
⑧ 処理「実行」 | 「処理「実行」」ボタンで、入力内容が更新されます。 登録： 入力内容が登録されます。 修正： 入力内容が更新されます。 削除： 担当者コード の内容が削除されます。 各処理の後確認メッセージが表示され、担当者コード入力へ戻ります。 （各項目はクリアーされます。）
⑧ 取消 | 「取消」で、入力内容が取り消され、担当者コード入力へ戻ります。 （キー項目は クリアーされ、他の項目は維持されます。）
３．各項目 入力 |
①会社コード 半角４文字 | 「登録」の時は、コードがすでに存在する場合は登録済メッゼジが有ります。 「修正」「削除」の時は、登録済として内容が表示されます。 コードがすでに存在しない場合は、「該当データが有りません」を表示。
②会社名 | 会社名 を入力します 必須 入力 願います。
③フリガナ | フリガナ を入力します 必須 入力 願います。
④その他 の項目 | 郵便番号～ファクシミリ までは自由記載
４．一覧表の処理内容
①一覧明細行のクリック | 各列の内容をクリックすると「各項目」の表示項目にデータがセットされ、 修正モードになり、項目の訂正＆更新処理が可能になります。 処理「実行」ボタンで更新できます。
    以下のサンプルは、Ver.2.4.0 までの内容です。
１．システム設定 の 画面構成
初期 表示画面です。 ＊：必須入力項目 処理選択の後に表示されるボタン
２．操作ボタンの内容
① 終了 | 画面を閉じ、プログラム終了します。
② 登録 | 担当者コードの入力になります。 コードがすでに存在する場合は登録済メッゼジが有ります。 また、「実行」「取消」ボタンが表示されます。(以下同様)
③ 修正 | 担当者コードの入力になります。
④ 削除 |
⑤ 参照 | 「担当者コード」の時に「実行」を押すと、明細が表示されます。 また、「担当者コード」なしで「実行」を押すと、最初のデータが表示されます。 ボタンは ⑥始 ～終 までが表示されます。
⑥ 始 ～終 まで | 「始」：最初のキー項目の表示 「＜」：一つ前のキーが表示 「＜」：一つ前のキーが表示 「終」：最後のキー項目の表示
⑦ 実行 | 「実行」ボタンで、入力内容が登録され、得意先コード入力へ戻ります。
⑧ 取消し | 「取消」で、入力内容が取り消され、担当者コード入力へ戻ります。 また、「得意先コード」未入力で押された場合、は「処理選択」に戻ります。
３．各項目 入力 |
①担当者コード 数字４文字 | 「登録」の時は、コードがすでに存在する場合は登録済メッゼジが有ります。 「修正」「削除」の時は、登録済として内容が表示されます。 コードがすでに存在しない場合は、「該当データが有りません」を表示。
②フリガナ | フリガナ を入力します 必須 入力 願います。
③担当者名 | 担当者名 を入力します 必須 入力 願います。 ４０文字まで漢字20文字
④Pass | パスワード を入力します 半角数字 ２０文字まで
⑤その他 の項目 | 部署～電話番号 までは自由記載

  ●「検索ボタン」を押すと「明細一覧」が表示されます。


マスタメンテナンス

  その他のメンテナンス

■ＰＤＦ登録・更新日・分類　修復


ＰＤＦ登録・更新日・分類　修復

  Ver.3.1.2 分類PDFファィルの情報メンテナンスを追加し、操作性を改良しました。
１．分類PDFファィルの情報メンテナンス の 画面構成
サンプル画面です。 処理開始用ボタン
① 修復条件 | ①PDFファイル１が設定されている ②分類のPDFファイルが割りついている その他の場合は「データメンテナンス」の検索された明細表示し、 選択項目セット後に内容を攪乱し、「明細更新」となります。
２．画面の起動方法
① 起動方法 | メニュー「ファイル」－「その他」－「PDF登録・更新日・分類 修復」を クリックすると起動画面が開きます。
３．操作ボタンの内容
① 終了 | 画面を閉じ、プログラム終了します。
② 処理開始 | 以下の入力項目を設定し、「処理開始」で「修復」を開始します。 設定項目： 「日付」の範囲、「会社コード」、領収書区分」
３．各項目 入力
①日 付 | 修復する「日付の範囲をセットする」 また、「今日」～「前年」までの項目選択でも入力か可能
②会社コード 半角４文字 | 会社コードを入力 初期値はメイン画面の「会社コード」となります。 また、「会社・検索」ボタンからも選択入力できます。
②会社・検索」 | 「会社・検索」ボタンを押すと、選択画面が表示されます。 「NO.」をクリックすると会社番号がセットされ、会社名が表示されます
③領収書区分 | 「領収書」 または 「発行領収書」をチェツクすると 修復対象となります。
４．修復内容の表示
①修復内容表示 | 「領収書」または「発行領収書」の修復内容、対象件数、更新件数を表示します。


  ご使用上の注意事項とトラブルＱ＆Ａ

  • Ｑ１．インストールの後、最初に行うことは？
  • Ｑ２．インストールでＤＡＴＡファィル（MDBファィル）が消えました。
  • Ｑ３．プリンターに「EPSON」を使用した場合のスキャンしたデータをPDFファイルで保存する方法
  • Ｑ４．バージョン２から３にバージョンアップすると、領収書の検索 分類検索　で　分類ｐｄｆの表示が無い。
  • Ｑ５．Ver.３からは、削除した請求書等のｐｄｆファィルが「\PDF\Backup」ホルダに移動されています。
  • Ｑ６．データベースファィル（ＭＤＢ）が壊れました。対応策は？
  • Ｑ７．標準の資料などの保存はどの様に行いますか？
  • Ｑ８．検収書を登録したい。方法は？
  1. Ｑ１．インストールの後、最初に行うことは？
    １．サンプル用の会社、事業所が一つ登録してあります。
  複数の会社で管理する場合は会社マスタメンテナンスで会社、事業所、区分など　自由に登録します。。
２．PDFファィル表示の確認
３．PDFファイルの読取　の確認
詳しくは、初めて使用の方を参照ください。
  2. Ｑ２．インストールでＤＡＴＡファィル（MDBファィル）が消えました。
    １．インストールの際には、ＭＤＢファィルの日付チェツクで　古いデータファイルの場合、
  Backup　ホルダに移動され、インストールのデータファィルがコピーされます。
    なお、Backup　ホルダには時系列で管理され「.mdb」の部分は「.001」「.002」の様に採番されます。
  再インストールの際は、上書きのチェツクが無い事をご確認ください。
２．プログラム、テキストファイル　なども同様な方法で管理されます。
  3. Ｑ３．プリンターに「EPSON」を使用した場合のスキャンしたデータをPDFファイルで保存する方法
      スキャンしたデータをPDFファイルで保存する際、
  「保存設定」画面で「テキスト検索可能PDF」の設定を行う事により、
  テキスト（文字）検索ができるPDFファイル（テキスト情報検索機能付きPDF）を作成することができます。
  （検索できるテキストは「日本語」のみです）
  「EPSON」のよくある質問より引用　　https://faq2.epson.jp/web/Detail.aspx?id=3133
    当方開発元では「Canon」で対応の為、詳しい方法は未定です。各ユーザにてご確認ください。
  4. Ｑ４．バージョン２から３にバージョンアップすると、領収書の検索 分類検索　で　分類ｐｄｆの表示が無い。
    バージョン２で分類ｐｄｆの情報が作成されていませんので、表示はされません。
一度データの更新されたデータは表示されます。
Ver.２とVer.３ののどのバージョンで作成されたかの判断が出来ます。
  5. Ｑ５．Ver.３からは、削除した請求書等のｐｄｆファィルが「\PDF\Backup」ホルダに移動されています。
    いつ削除されるのですか？
    データファィルの削除でｐｄｆファイルは「\PDF\Backup」ホルダに移動されます。
再度、異なる日付・仕入先で作成する場合に利用出来ます。
最終的に不要となった段階で「Windows のエクスプローラ」などのツールで削除願います。
  6. Ｑ６．データベースファィル（ＭＤＢ）が壊れました。対応策は？
    その１・・バックアップしていた圧縮ファィルを解凍し、DATAホルダに戻します。
        解凍ツールは各自準備ください。
その２・・データがすべてなくなりますが、空ファィルから戻します。
          SystemホルダにマスターＤＢファィル\[MKpdfMST.mdb]、[MKpdfBunMST.mdb]が存在します。
          [MKpdfMST.mdb]を[\DATA\MKpdf.mdb]、[MKpdfBunMST.mdb]を[\DATA\MKpdfBun.mdb]にコピーします。
その３・・再インストールでデータベースファィルを上書き指定します。
          この場合、データベースファィルは初期となり、データが削除状態となります。

お奨めは、その１です。　小マメにバックアップをする事です。
  7. Ｑ７．標準の資料などの保存はどの様に行いますか？
    その１・・会社名前を資料として登録します。
  その後、この会社で金額￥０、日付、資料などの名称で「仕入先」の名前で登録し、資料をｐｄｆファイルで登録します。
  検索の際は資料用の会社で検索します。
例えば、「会計資料」・・・仕訳帳、元帳、決算書、確定申告書　　なとをｐｄｆで登録
        「税務提出資料」・・・「青色申告」、「法定調書」「所得税徴収高計算書」　などをｐｄｆで登録
  また、同一資料名で金額￥０の処理では、登録済となりますので、「資料名」を「資料名２」などとして登録します。
  8. Ｑ８．検収書を登録したい。方法は？
    １．システム設定を開きます。
２．その後、「分類設定」を選び、No.0～ No.8　までの項目を変更し更新します。
  例えば、検収書を登録の場合、NO.7の「他書類A」を「検収書」に変更し、更新します。
  その他の項目も自由に変更可能ですが、書類の登録する最初に変更することを推奨します。
  9. Ｑ９．
  10. Ｑ１０．


Ver.３　ご使用上の注意事項とトラブルＱ＆Ａ

  1. Ｑ１．バージョン２から３にバージョンアップすると、領収書の検索 分類検索　で　分類ｐｄｆの表示が無い。
    バージョン２で分類ｐｄｆの情報が作成されていませんので、表示はされません。
一度データの更新されたデータは表示されます。
Ver.２とVer.３ののどのバージョンで作成されたかの判断が出来ます。
また、Pdfファイルのみ入力すると、関連性の更新がなく、分類ｐｄｆの表示がされません。
必ず、ファイル名は「PDF Copy」ボタンにて登録ください。
  2. Ｑ２．Ver.３からは、削除した請求書等のｐｄｆファィルが「\PDF\Backup」ホルダに移動されています。
    いつ削除されるのですか？
    データファィルの削除でｐｄｆファイルは「\PDF\Backup」ホルダに移動されます。
再度、異なる日付・仕入先で作成する場合に利用出来ます。
最終的に不要となった段階で「Windows のエクスプローラ」などのツールで削除願います。
  3. Ｑ３．Ver.３からは、領収書データメンテナンスの明細表示で「分類」表示がスペース　または、ALL "0" で表示される現象が発生。
    考えられる原因として、pdf Fileを割り付けた後に「明細更新」を押さない場合に発生しています。
  以下の方法で対応できます。
その１．明細を選択後、「」選択項目セット」で表示し表示、pdf File の割付を確認し、「明細更新」を押します。
その２．多くのデータで発生している場合は、「ＰＤＦ登録・更新日・分類　修復」にて一括更新することが可能です。
        ＰＤＦ登録・更新日・分類　修復　＜＝＝　ヘルプを見る
  4. Ｑ４．Ver.３.2.0からは、．「消費税複数明細 入力」が可能になりましたが、
        会計ソフトからの作成された仕訳データからデータ取込がされません。
    会計ソフトでのデータ入力方法がバージョンによって明確ではありませんので、
請求書のデータ取込後に、「消費税複数明細 入力」にて対応ください。。
  なお、消費税の集計は会計ソフトの消費税一覧表などの使用をおすすめ致します。


  改定履歴

  ◎領収書PDF管理システム　[RyosyuPDF] Ｖ３　の改定

  ●　Ver.3.2.0 改訂日付 2024.03.10
      １．機能追加
        １．「消費税複数明細 入力」のリリース＜＝＝見る
          複数の消費税が有る場合の入力を提供。
          また、検索画面にもマウスの移動で複数明細の表示とした
          （免税事業者の個人事業主には不要な機能なので無視、又はメモ程度で入力は可能です。）
        ２．仕分データの取込み　画面に追加・更新の選択モードを追加　＜＝＝見る
    ●インストール方法
      今回は Ver.3.1.2 と同様に Ver.3.0.0 の差分にてインストーラを公開しました。
      新規ユーザは「Ver.3.0.0」のインストールの後に、「Ver.3.2.0」をインストール。
      ◎インストールのパスワードは Ver.2 を使用下さい。
  ●　Ver.3.1.2 改訂日付 2024.02.10
      １．機能追加
        １．「ＰＤＦ登録・更新日・分類　修復」を機能拡張しました。　＜＝＝見る
          Ver.2からのユーザの方で分類を使用する方は、一度修復の処理を実行してください。
          （考えられる原因として、pdf Fileを割り付けた後に「明細更新」を押さない場合）
        ２．「領収書データ　メンテナンス」などのデータ取込画面での検索表示の改良＜＝＝見る

    ●インストール方法
      今回は Ver.3.1.0 と同様に Ver.3.0.0 の差分にてインストーラを公開しました。
      新規ユーザは「Ver.3.0.0」のインストールの後に、「Ver.3.1.2」をインストール。
      ◎インストールのパスワードは Ver.2 を使用下さい。
  ●　Ver.3.1.0 改訂日付 2024.01.15
      １．機能追加
        １．国税庁番号公表サイトでの「インボイス番号検索」を追加
            以下の画面で検索のためのインボイス番号を設定し
            国税庁番号公表サイトの画面を表示します。
            変更プログラム
            １．「メインプログラム」・・・RyosyuM3.exe　＜＝＝見る
            ２．「仕入先メンテナンス」・・RSHIRM.exe　　＜＝＝見る
            ３．「得意先メンテナンス」・・RTOKUIM.exe　　＜＝＝見る
        ２．１．の機能の為に、システム設定で「国税庁番号公表サイト」の
            アドレスメンテナンス項目を追加しました。　＜＝＝システム設定を見る
        ３．ＤＢバックアップを年度別指定を追加しました。＜＝＝バックアップを見る
        ４．不具合の改定
            １．領収書、発行領収書の分類登録の有る明細の表示後に新規登録すると、分類登録が無いのに間違って有る様に表示する。
              過去データの修正方法は、一度削除した後に、新規登録願います。
              （今回のバージョンの後のデータは正しく登録されます。）
    ●インストール方法
      今回は Ver.3.0.2 と同様に Ver.3.0.0 の差分にてインストーラを公開しました。
      新規ユーザは「Ver.3.0.0」のインストールの後に、「Ver.3.1.0」をインストール。
      ◎インストールのパスワードは Ver.2 を使用下さい。
  ●　Ver.3.0.2 改訂日付 2023.11.30
      １．不具合　等の改定
        １．「領収書、発行領収書の検索 分類検索」で「選択項目セット」が正しく反映されない件を改善。
          また、「set」ボタンで表示用一覧表画面のデザインも変更とした。
        ２．検索画面の項目表示位置ズレを修正（会社名、適用、借方、貸方）
    ●インストール方法
      今回は Ver.3.0.1 と同様に Ver.3.0.0 の差分にてインストーラを公開しました。
      新規ユーザは「Ver.3.0.0」のインストールの後に、「Ver.3.0.2」をインストール。
      ◎インストールのパスワードは Ver.2 を使用下さい。
  ●　Ver.3.0.1 改訂日付 2023.11.15
      １．不具合　等の改定
        １．領収書データメンテナンス後に「検索画面」でデータ表示できない改善。
          データロックを解除する変更をした。
          また、検索画面の表示の際は「領収書データメンテナンス」画面を閉じる事とする。
    ●インストール方法
      今回は Ver.2.5.2 と同様に Ver.3.0.0 の差分にてインストーラを公開しました。
      新規ユーザは「Ver.3.0.0」のインストールの後に、「Ver.3.0.1」をインストール。
      ◎インストールのパスワードは Ver.2 を使用下さい。
  ●　Ver.3.0.0 改訂日付 2023.04.30
      １．資料の登録を以下の「分類」毎にｐｄｆを登録する機能を追加しました。
          1.領収書、2.請求書、3.契約書、
          4.預金関係、5.見積書、6.注文書、
          7.検収書、8.その他書類Ａ、9.その他書類Ｂ
          詳しくは「領収書データ　メンテナンス　Ver.３」のページを参照下さい。
      ２．「分類」機能の追加により以下の機能、画面、検索画面などを追加
          １．システム設定画面に、「分類項目設定」を追加。
          ２．分類用データベースファイル「MKpdfBun.mdb」を追加。
          ３．領収書、発行領収書の検索に、各書類の「分類」ｐｄｆの検索を追加。
              また、各分類の書類登録毎の指定検索、並び替えが可能で高速検索表示が可能となります。
      ３．削除データでの対応として、ｐｄｆファイルは削除せず、[\PDF\Backup]ホルダに移動。
          （別な登録データとして再使用が可能。不要なｐｄｆの場合はユーザにて、[\PDF\Backup]ホルダから削除）
      ４．仕分データの取り込みの改良
          借方金額 を設定し、貸方金額が無い場合は 借方金額を用いる。（諸口仕訳対応）
          発行請求データからの変換で「MJSかんたん」「弥生会計」の判断が一部で漏れがあり機能追加。
      ５．作業用「ログ検索」に担当者ログ出力を追加しました。
          作業用「ログ検索」は　資料毎に日付時間順に表示。
          担当者ログは、管理者パスワードの入力が必要で、担当者のパスワード入力を日付時間順に表示します。
      ６．領収書データ　メンテナンス
          元ファイル等１２３の場合、「ＰＤＦファイル以外も登録が可能となります。」
      ７．不具合　等の改定
        １．印刷画面を正しく表示可能としました。
          ただし、領収書の単独画面の場合、現在表示不可です。・・印刷の場合は子画面を利用下さい。
        ２．仕分データ取込での日付設定の修正
    ●インストール方法
      今回は Ver.3.0.0 の新規インストーラを公開しました。
      Ver.3.0.0 を使用する方は　新規インストール下さい。
      D/B File MKpdfBun.mdb」、ホルダ「\PDF\Backup」が追加されます。
      ◎インストールのパスワードは Ver.2 を使用下さい。

  ◎領収書PDF管理システム　[RyosyuPDF] V2　の改定

  ●　Ver.2.5.4 改訂日付 2023.02.28　　Ver.3.0.0 の公開の為　未公開
      １．各種検索機能で金額の上にマウスを移動すると、[税額]が有る時に表示する項目に、
        [備考]も表示する様に機能追加。
    インストール方法
      今回は Ver.2.5.2 と同様に差分にてインストーラを公開しました。
  ●　Ver.2.5.2 改訂日付 2023.01.30
      １．「領収書、発行領収書の検索・集計」画面に税率を選択項目に追加
          a.税率０で　税額がある場合、内税で表示
          b.税率が有り、税額が「０」の場合は、選択項目「ERR」の選択で表示可能
      ２．仕分データの取り込みで「内税」「外税」の表示を「摘要」欄に表示
      ３．システム設定で「消費税率」をメンテナンスする様に変更。消費税率変更に対する改定
        従って各種画面の「消費税率」はシステム設定の設定順で表示します。
        例えば、[13.0][10.0][8.0][0.0][0.0]の様に設定します。
        規定値は[10.0][8.0][0.0][0.0][0.0]となります。
    不具合修正
      １．仕分データの取り込み・「領収書」「発行領収書」での更新にて
          消費税の　率、金額が更新されない　現象を修正
      ２．弥生会計の仕分データの取り込みについて　改修
          消費税の率、金額が更新されない
    インストール方法
      今回は Ver.2.5.0 と同様に差分にてインストーラを公開しました。
  ●　Ver.2.5.0 改訂日付 2022.12.30
    改定内容
      １．マスタメンテナンスの改良について
        操作性を考慮し、マスタメンテナンス「会社」「得意先」「仕入先」「担当者」を改良しました。
      ２．マスタ表示のデータ件数について
        Ver.2.4.0までの「会社」「得意先」「仕入先」の件数は
        現在２０件数としています。　表示件数を「制限なし」とし、表示可能としました。
        ただし、「会社」は現状通り「２０件」としています。
      ３．システム設定(ｲﾝﾎﾞｲｽ情報)を追加しました。
        詳しくは「クイックガイド」－「システム設定(ｲﾝﾎﾞｲｽ情報)」のページを参照
        （１万円未満の仕入れはインボイスを不要 　・・など　に対応）
    インストール方法
      今回は Ver.2.4.0 と同様に差分にてインストーラを公開しました。
  ●　Ver.2.4.0 改訂日付 2022.11.30
    改定内容
      １．プログラム起動時に「担当者」の入力を追加しました。
          （\RyosyuPDF\SYSTEM\MKPass.mdbにて管理する）
        [メニュー]-[ファイル]に起動時のパスワード入力　を追加
        また、パスワードの機能も追加し、「担当者」メンテナンスで行います。
        「担当者」入力管理を行わない場合は「MKPass.mdb」を名称変更する。
      ２．領収書、発行領収書　の　検索・集計　の機能拡張
          「インボイス有り」のみ表示出来るチェツクボックスを追加
      ３．修正データ「ログ」表示　の機能拡張
        １．「変更内容」に修正内容をより詳しく表示。
        ２．「ＯＰ担当」に入力担当者名を表示。
    不具合改修
      １．修正データ「ログ」表示の機能拡張により「変更内容」の表示の不具合を改修
    インストール方法
      今回は差分にてインストーラを公開しました。
      ただし、「担当者マスタ」対応として、ファイル「MKPass.mdb」のコピーの選択があります。
      ファイル「MKPass.mdb」が有ると、「担当者」の管理が可能になります。
  ●　Ver.2.3.4 改訂日付 2022.11.10
    改定内容
      １．各種検索機能で、金額の上にマウスを移動すると、[税額]が有る時に、
        [取引先（得意先）]、[金額]，[税率]、[税額]、[インボイス登録番号]を表示する。
      ２．検索集計の集計について・・
        「仕入先の行」での小計から「並び替えた行」での小計を表示する。
      ３．検索表示の制限事項を解除　について
        「領収書の検索」と「領収書の検索・集計」及び
        「発行領収書の検索」と「発行領収書の検索・集計」を
        同時に表示することを制限していましたが、可能にする様に改定した。
      ４．「領収書　登録・変更　単独」及び「発行領収書　登録・変更　単独」の画面を
        「領収書　登録・変更」及び「発行領収書　登録・変更」と同等な機能としました。
      ５．領収書データ　メンテナンス　などの　メンテナンスにおいて
        仕入先名を長い文字（半角７８文字、漢字３９文字）以上の場合、
        「PDFファィル名」が「１００文字」を超えるとエラーになるので、エラーメッセージを表示しました。
        また、元ファィル等１２３　のＰＤＦ名が「１００文字」超えるとエラーになるので、
        「エラーメッセージ」を表示しました。　元ＰＤＦファィル名を変更後に、再度選択下さい。

        今回は差分にてインストーラを公開しました。
  ●　Ver.2.3.2 改訂日付 2022.11.01
    改定内容
      １．仕分けデータからの更新でデータが追加されない現象。
         原因：Ver.2.3.1 の際に、テスト環境のリセットを忘れて公開。
             テスト環境を外しプログラム作成
        今回は差分にてインストーラを公開しました。
  ●　Ver.2.3.1 改訂日付 2022.10.18
    改定内容
      １．「検索」において税率が１０倍で表示される。
         原因：内部データとして税率が少数での対応を考慮し、１０倍して保存しています。
               正しく％表示としました。また０の場合は未表示とします。
        今回は差分にてインストーラを公開しました。
  ●　Ver.2.3.0 改訂日付 2022.10.12
    改定内容
      １．「発行領収書・検索」での「選択項目セット」が反映出来ない現象です。
         今回は差分にてインストーラを公開しました。
  ●　Ver.2.2.0 改訂日付 2022.09.20
    改定内容
      １．「各種検索画面」にて表のサイズ変更スライダーで　文字フォントサイズも変更可能となる「チェツク」枠を追加しました。
          チェツクで文字の変更も可能となります。
      ２．「検索機能の改良」・・検索画面の機能拡張
        PDF File の無い場合、バックカラー黄色で表示
        １．「領収書データ　メンテナンス」、２．「領収書、発行領収書の検索」
  ●　Ver.2.1.1 改訂日付 2022.09.30
    改定内容
      １．マスターメンテナンスの起動について
          システム設定で「更新」ボタンを押さない時に、起動しない場合が有り、
          起動可能とする様に変更しました。
  ●　Ver.2.1.0 改訂日付 2022.08.22
        領収書PDF管理システム　[RyosyuPDF] V2　の改定　及び　不具合改修
    不具合改修
      １．各検索画面の明細件数について
          設定の明細件数を超えて　明細が有る場合、
          エラーが発生し、プログラム終了していた。
          この場合メッセージを表示しました。
          また、設定の明細件数を変更すると　設定件数まで表示されます。
      ２．MS-office 2010 以降のインストールパソコンでデータ更新ときに「3164エラー」が発生。
          テーブんの項目タイプを変更しました。<== Ver upではDBが変更されます。
    改定内容
      １．メインプログラムのボタンメニューの変更
          詳しくは、メニュー・ツールバー　構成　を参照願います。
            例えば、「領収・検索」の右ボタンクリックで
          ２つの画面起動が選択できます。
      ２．修正ログ表示の画面　の設定明細件数　について
          他の検索画面と同じ件数を表示していましたが、
          専用の件数を表示とし、規定値は1000件としました。
          また、変更件数は以後　継続されます。
      ３．領収書データ　メンテナンス　・・　（記入もれが有り後日追加）
          発行区分=１電子の時、PDF Copyの１(４つのうち一番上)を設定すると、
          元ファイル等１にも　PDFファイル元データがセットされ、保存ホルダにもファィルがコピーされる。
      ４．ヘルプの記述追加
          説明不足の内容の記述を修正、追加しました。
        多少記述不足な部分がありますが、今後、少しづつ改定する予定です。
  ●　Ver.2.0.0 改訂日付 2022.05.20
        領収書PDF管理システム　[RyosyuPDF] V2　をリリース
    機能一覧
      １．集計・検索　画面を追加・・・　項目の並び替え後で、「集計」ボタンで集計が行える
      2.　マスタメンテナンス画面に「検索ボタン」「明細一覧」を追加。
          「検索ボタン」を押すと「明細一覧」に表示されます。
  ●　Ver.1.0.0 改訂日付 2022.01.01
        領収書PDF管理システム　[RyosyuPDF]　をリリース
    機能一覧
      １．領収書pdfを保存する。
        ａ.pdfを検索する形式で出力、
        ｂ.ネットでの送付されたそのままのPDF形式で保存
      ２．領収書pdfを検索する。
          「領収書の作成日付」「領収書の仕入先名」「領収書の金額作成日付」で検索
      ３．仕訳帳データからデータを作成するツールを提供
        ａ.「MJSかんたん！青色申告」の仕訳帳データ－Excel(2003)から自動作成が可能。
        ｂ.「弥生会計」のエクスホート仕訳帳データ－Excel(2003)から自動作成が可能。
      ４．保存された領収書pdfをHTMLブラウザ、専用画面で表示する。
         (ただし、PDF表示のソフトが必要です。)
      ５．PDF変更した場合のログデータを出力します。
        また、表示するプログラムを提供。
      ６．データ入力担当者を限定する方法として、
        プログラム起動時に、パスワード入力とします。
    インストールの提供
      ．バージョンは　Ver.1.0.0 とする。
      ．ブログラムの種類
        「RyosyuM.exe」「RpdfSYS.exe」「RpdfSai.exe」
        マスターメンテナンス－「RTOKUIM.exe」「RSHIRM.exe」「RKAISM.exe」
        PDF変更ログ表示－「RLogDsp.exe」


サポートなどのご案内

  ホームページ、サポートなどのご案内

領収書PDF管理システム　[RyosyuPDF] のホームページ　＜＝＝ ブラウザで開く
  (　https://www.maitonclub.com/RyosyuPDF/ )

ホームページにで　いろいろな連絡内容を記述していますので、
上記ホームページをクリックして御覧ください。