  領収書PDF管理システム　[RyosyuPDF]

  領収書PDF管理システム　注意事項

◎　特　徴

    １．会計ソフトがなくてもPDFファィルを読み取り登録・表示する管理が可能です。
    ２．ネットワーク接続することなく、パソコン・スキャナーがあれば管理が可能です。
    ３．パソコンは　Windows 7, 8.1, 10, 11 が動作すればＯＫです。
        （　動作環境 に記述していますので参照ください。）
    ４．PDF変更した場合のログデータを出力し、検索表示が可能です。
    ５．プログラム起動時に、パスワード入力にて、データ入力担当者を限定できます。
    ６．領収書PDFデータの検索、並び換えがいろいろ出来ます。・・詳しくはPDFの検索のページを参照
        （選択項目は　１．日付の範囲、　２．仕入先名(曖昧検索可能)　３．金額、　４．会社CD）
    ７．ネットからのPDFデータの場合原本データ、及び検索用PDFファィルの２つのPDFファィルを管理できます。
         その他の機能は　領収書データ　メンテナンスのページを参照
    ８．プログラム終了時に、管理用DBファィル、及びＰＤＦファィルを圧縮ファイルで５世代管理で保存できる。
        （保存の有無が選択出来る）

まず、「はじめに」から御覧ください。

  「電子帳簿保存法」の　電子保存の義務化に2年の猶予　税制改正大綱　などが記述しています。
領収書PDF管理システム　[RyosyuPDF] : This program is a system that manages PDF files of receipts.
Copyright by [RyosyuPDF] & kanazawa S.Miyakawa, 2022 All right reserved


はじめに、機能

電子帳簿保存法 に対応するため、紙の領収書をpdfファィルとして保存

    ◎2022年1月1日に施行される電子帳簿保存法の改正により、電子取引情報の保存ルールが変わります。
    今までは紙で印刷したものを原本として保管できましたが、2022年1月1日以降は取引情報を原則電子データで、

    かつ電子帳簿保存法の要件に則って保存する必要があります。

  2022年（令和4年）1月1日に施行された改正電子帳簿保存法について、
国税庁は2021年末、「電子保存の義務化」の猶予が2年間認められる要件について解説を公表しました。
「やむを得ない事情」と「整然とした形式及び明瞭な状態で出力されたものを準備しておく」という2つの条件を満たす必要があります。
詳しい要件を整理しました。

    改正電子帳簿保存法、電子保存の義務化に2年の猶予　税制改正大綱
  猶予が認められるための2つの条件
  電子データによる保存が間に合わない事業者に向けて、国税庁は「令和5年（2023年）12月31日までに行う電子取引については、
保存すべき電子データを書面に出力して保存し、
税務調査等の際に提示又は提出ができるようにしておいていただければ差し支えありません」と猶予を認めています。

領収書PDF管理システム　[RyosyuPDF]　の　機能一覧

    １．作成された　PDFファィルは自社のコンピュータで保存され、外部にもれが発生しないので完全に安心・安全です。
    ２．領収書の「作成日付」「仕入先名」「金額」で検索出来、いつでも　一発検索で　指定のブラウザで表示できます。
      検索キーは、領収書の「作成日付」「仕入先名」「金額」で、「仕入先名」は一文字の検索、また、複数の文字検索も可能。
    ３．「作成日付」「仕入先名」「金額」の情報は会計システム情報の仕訳帳データからデータを作成するツールを提供。
      会計システムは「.「MJSかんたん！青色申告」、「弥生会計」のExcel(2003)を利用可能。
                                  ●　 電磁的記録による保存は、次の3種類があります。
    １．.紙での領収書・・スキャナーで読み取り　領収書の「作成日付」「仕入先名」「金額」で保存します。
    ２．メールでの領収書・・ファイルをPDFファィルで出力し、領収書の「作成日付」「仕入先名」「金額」で保存します。
    ３．ネットでPDFファィルで領収書・・ファイルをPDFファィルで出力し、領収書の「作成日付」「仕入先名」「金額」で保存します。
詳しくは、「動作環境」「制限事項」を御覧ください。

●電子帳簿保存法とは
国税庁によると、電子帳簿保存法とは、税法により、紙での保存が義務づけられている帳簿書類について、
一定の要件を満たせば、電磁的記録（電子データ）による保存を可能とすることなどを定めた法律です。

  各税法で原則として紙での保存が義務づけられている帳簿書類について一定の要件を満たした上で電子データによる保存を可能とすること、および電子的に授受した取引情報の保存義務等を定めた法律です。
    電子帳簿保存法上、電磁的記録による保存は、大きく3種類に区分されています。
    １．電子帳簿等保存（電子的に作成した帳簿・書類をデータのまま保存）
    ２．スキャナ保存（紙で受領・作成した書類を画像データで保存）
    ３．電子取引（電子的に授受した取引情報をデータで保存）


test2領収書PDF管理システム [RyosyuPDF]

  動作環境

システム 環境 | システムに必要な条件 | 推奨する環境
●稼働OS | Microsoft Windows 10 32bit版 / 64bit 版 Microsoft Windows 11 64bit 版 （Microsoft Windows 7 32bit版 / 64bit 版 ） | Windows10 32/64
●Webブラウザー | Google Chrome Windows Microsoft Internet Explorer 11.0 32bit版 Microsoft Edge（Chromium版） ただし、ＰＤＦファイルが表示可能なもの |
●スキヤナー | Canon製 Inkjet Multifunction Printer ex. Canon TS6000 serie 、Canon TS8130 series XPS など |
●ＰＤＦ作成ソフト | 各種 いろいろ また、Canon My Imaage Garden は画像スキャニング後、 直ちに、PDFファイル出力が可能。・・・推奨する機能 (メニューのスキャニングを選択し、ドライバーを選ぶと 帳票のスキャニングが可能です。) | Canon My Imaage Garden
●領収書PDF管理システム 開発言語 | Visual Basic 6.0 32bit system |
ハードウエア 環境 | システムに必要な条件 | 推奨する環境
●ＣＰＵ | ペンティアム ５００ＭＨｚ以上 | Intel(R) Core(TM) Ｉ３以上
●ハードディスク | ４GBバイト以上の空き容量 | ５０GB以上の空き
●メモリ | ４ＧＢ以上 | ８ＧＢ以上
●ディスプレイ | 1024×768ドット以上の解像度 ・Ｈｉｇｈ－Ｃｏｌｏｒ（６５５３６色）以上 | 1366 * 768、1920*1080 ・Ｈｉｇｈ－Ｃｏｌｏｒ
●プリンター スキヤナー | PDF作成可能なもの | Canon製 Inkjet Multifunction Printer
推奨動作環境 快適にお使いいただくためには推奨する動作環境をお勧めいたします。
    ◎　領収書ＰＤＦ保存システム　の　概　要
画面 機能 | 画面一覧 | その他
●データ入力 | ◎領収書-処理 １．領収書 登録、変更、削除 ２．領収書 検索 ◎発行・領収書-処理 １．発行・領収書 登録、変更、削除 ２．発行・領収書 検索 | ◎領収書、発行・領収書 の登録では「領収書」の ＰＤＦファィルでの保存が可能。 また、ＰＤＦファィルのクリックで 「領収書」のＰＤＦファィルの表示が出来ます。 ◎検索機能では、 「日付」「得意先 Or 仕入先」「金額」「会社、事業所」などの 検索キーで、検索が可能です。 （ 得意先 Or 仕入先 ではあいまい検索が可能 ） あいまい検索とは ： 指定した検索キーワードを「含む」データを探す検索
●データ移行・変換 | ◎弥生会計 仕訳 Excel-2003 形式(Ver.5以降) ◎「MJSかんたん！青色申告」の仕訳帳 Excel(2003) |
●マスターメンテナンス | ◎会社（事業所） マスタメンテ ◎仕入先 マスタメンテ ◎得意先 マスタメンテ | 注意事項： 会社（事業所）は設定願います。 他のマスタの登録は不要ですが、 常に使用する場合は入力が簡略出来ます。
●システム 操作 | ◎システム設定 ◎データーベースファイル(DB) 最適化 | システム設定で、ホルダの変更が可能になり、 又、ＤＢの容量オーバー、検索性能の改善に有効化となります。
●メンテナンス モード | ◎データ入力時のログ情報出力 ◎データ移行・変換時のログ情報出力 | 出力 有無の設定が可能 既定値は、「有」 となります。
●印刷機能 | ◎画面のイメージを印刷画面の表示 & 印刷指定 ◎検索の表での[Excel]への出力 又、Text形式も可能 |
●ヘルプ | ◎各画面から [Ｆ１] にてヘルプを表示 |


  制限事項


領収書PDF管理システム [RyosyuM]

  システムの使用規定

領収書PDF管理システム　[RyosyuM] : This program is a system that manages PDF files of receipts.
Copyright by [RyosyuM] & kanazawa S.Miyakawa, 2022 All right reserved


  ｲﾝｽﾄｰﾙ/ｱﾝｲﾝｽﾄｰﾙ


  インストール

１．インストールの方法－１
  ①インストールファイル.
  起動方法
  1. クリックしてインストール用ファイル（RyosyuPDFinst.EXE）をパソコンに保存します。
  2. 保存したインストール用ファイル（RyosyuPDFinst.EXE）をダブルクリックして実行します。
  3. 領収書PDF管理システムのインストールが開始されます。
  ②インストール操作
  1. 領収書PDF管理システムのインストール画面が開きます。
  2. スクロールして文章をお読みいただき、インストールを続ける場合は「次へ」をクリックします。
    （注意事項：パスワードの記述が文章の最後有ります。）
  3. インストール先を指定する画面が開きます。
    通常はそのまま「次へ」をクリックします。
    初期インストール先は　以下の様に表示され、Windows １１、1０、８、７、と異なります。
    規定値は「C:\RyosyuPDF\」です。
    Windows ７、８、１０、１１、の場合は絶対に「C:\Program Files\RyosyuPDF\」に変更しない様に願います。動作保障いたしません。
    推奨するホルダの設定； システムドライブ(Cドライブ)以外のホルダを指定願います。
      （オッズテータは随時保存しますので、毎週増大していきます。）
  4. コンポーネントの選択について
      新規インストール時には規定値で実行します。バージョンアップ　及び、
    再インストールの時に各チェツクを設定します。

２．コンポーネントの選択について
処 理 内 容 | 11,10,8 規定値 | 7 規定値 | 説 明
１．プログラムの上書き | レ | レ | プログラムを上書きしない場合は「チェツク」を外します。 「チェツク」の時は最新プログラムに上書きされます。
２．SYSTEMホルダの上書き | レ | レ | SYSTEMホルダに書き込むファイルを上書きしない場合は「チェツク」を外します。 「チェツク」の時は最新データに上書きされます。
３．データ変換データベースの上書き |  |  | 「\DATA\OPmstJV.mdb」を強制的に上書きする場合にチェックします。 通常は「\DATA\OPmstJV.mdb」が古い、無い場合（新規）に出力されます。
４．スタートに「プログラムグループ」を表示 | レ | レ | 出力しない場合に「チェツク」を外します。 特にバージョンアップ、再インストールの時に有効です。
５．ディスクトップに「アイコン」を表示 |  |  | 表示したいときに「チェツク」します。インストール後からも表示は可能です。
６．以下のカスタムコントロール、ＤＬＬ登録処理をする。 | レ | レ | バージョンアップインストール時に「チェツク」を外すと、短時間で処理できます。
７． １．[ＶＢ６用] の登録時に 置換しない。 | レ |  | ・ＶＢ６用専用のコントロール、ＤＬＬです。 1１、1０、８、７、の場合に登録エラーになる場合がありますので、「チェツク」有りにすると、 各モジュールがすでにインストール済みの場合は登録は行いません。 プログラム起動時に「OCX、DLLが古い」などのエラーメッセージが表示された場合、 ※※ 原因として、すでに同一のOCX、DLLがインストール済み、かつ古い場合に表示されます。 古いのOCX、DLLで動作中のプログラムに影響が無いかを確認し、 このチェツクをはずして再インストール願います。※※
８． ２．[RyosyuPDF用] の 登録時に置換しない。 |  |  | RyosyuPDF 専用のコントロール、ＤＬＬです。 「チェツク」はＶＢ６用と同様です。 チェックが無い場合は、古いOCX、DLLは置換されます。 プログラム起動時に「OCX、DLLが古い」などのエラーメッセージが表示された場合、 ※※ ＶＢ６と同様、このチェツクをはずして再インストール願います。※※ チェツクを外した「サンプルの画面」を見る
３．インストールの方法－２
  ③　インストール操作－２
  5. インストール完了をお知らせする画面が開きます。
    インストール進行中の画面。
  6. システム設定画面が開きます。
    内容を確認して、「更新」ボタンを押します。　「終了」で画面が閉じます。
    ※注意　EXCEL APP の設定について　「システム設定」を確認ください。
  7. ヘルプ画面が開きます。内容を確認し、画面を閉じます。
  8. 領収書PDF インストール　最終処理の画面が表示されます。
    プログラム起動時のパスワード「５桁の数字」が表示されます。
    パスワードを控え　保存ください。
    「最終処理を実行する」    をクリックするとインストールは終了します。

    注意事項　「最終処理　中止」では　プログラム起動時は出来なくなります。
  9. インストールが完了しましたので、完了をクリックしてください。


  アンインストール

    注意事項：　アンインストールすると　インストール時の情報、ファイルは削除されます。

１．アンインストールの方法
  1. コントロールパネル」＞「プログラムのアンインストール」をクリックします。
  2. 「RyosyuPDF」を選択し、アンインストールと変更を選択又は、ダブルクリックします。
    アンインストールオプション　のアンインストール　の画面が表示します。
  3. .「次へ」を押して進みます。
    後は画面の指示に従って処理を継続して、終了します。


  システム　ご利用の前に


  日付と時刻の設定

  この機能はパソコンのWindowsの機能を使用します。詳しくはWindowsを参考願います。

  1.タスクバーの「時計」を左クリック
  2.日付と時刻の調整　をクリック
  3.現在時刻の変更
    自動で設定、手動で設定、又は　今すぐ同期　を選択し、時間の設定を行います。


  Ｗｉｎｄｏｗｓの画面設定

  この機能はパソコンのWindowsの機能を使用します。詳しくはWindowsを参考願います。

  1.Windows の設定画面を開きシステムを選択
  2.ディスプレイ　を選択する。
  3.画面の配置を選択後、画面を選び「拡大縮小とレイアウト」で
    「テキスト、アプリ、その他の項目のサイズを変更する」で
    100% などのサイズを選択する。
    また、ディスプレイの解像度を選択する。


  クイックガイド

■初めて使用の方
■データ変換ＤＢファィルの最適化
■ＤＢファィルデータ整理
■システム設定
■バックアップ


  初めて使用の方

１．システムのインストール |
２．PDFファイルの読取機のセット | 動作環境のスキャナーで記述の推奨機での設定について Canon My Imaage Gardenの設定について記述します。 ①「Canon Quick Menu」を起動し、「My Imaage Garden」を起動すると プリンター情報の取込後に、スキャンを選択します。 ②スキャン設定情報にてスキュン情報をPDF出力するために、 以下の設定を行います。 「スキャン設定」-「ScanGear」で １．.「データ形式」をPDF ２．「PDF圧縮」を「高圧縮」を選択 以上の設定で、読み取り画像ファイルは「PDF」となります。
３．PDFファイルの読取 | 動作環境のスキャナーで記述の推奨機での設定について Canon My Imaage Gardenの設定について記述します。 「メニュー」の「ドライバー」をクリックし、画像をスキャンします。 (詳しくはソフトのヘルプを参照ください。) 他のソフトを利用の場合は「画像をスキャン」ファイルをPDF出力します。
４．領収書PDF管理システムの起動 | インストールで作成された [RyosyuM.exe - ショートカット]をクリックします。
５．マスターの登録 | ①会社Mメンテナンス にて「会社」又は「事業所」を登録する。必須 ②仕入先Mメンテナンスにて「仕入先」を登録する。 自由登録 ③得意先Mメンテナンスにて「得意先」を登録する。 自由登録
６．領収書データ メンテナンス | 領収書データ メンテナンスを起動し、領収書PDFを登録する


  データ変換ＤＢファィルの最適化


  ＤＢファィルデータ整理


  システム設定

１．システム設定 の 画面構成
◎現在のバージョンは 左側画面のホルダ項目のみ対応
２．選択処理項目の概要
① 初期値 | システムの既定値の情報をセットします
② 終了 | 画面を閉じます。
③ 更新 | 画面の項目を更新します。
④ 保存戻し | 最初に表示した項目の内容を表示します。
⑤ ？ ヘルプ | ヘルプの表示は 「F1」キーにて表示されます。
３．ホルダ設定 ・・・ 「参照」ボタンを押すと以下の項目が選択出来、ホルダがセットされます。
①プログラム | いろいろなプログラムが起動されるホルダです。既定値はインストーラで設定されます。
②システムホルダ | システム関係のファィルが保存されています。 (例：ヘルプファイル)
③ログ保存ホルダ | 登録情報のメンテナンスで保存するファィル。 Ver.1.1.0からは\DATA\MKpdfLog.mdb
④仕訳DATAホルダ | 仕訳データからデータ移行する際のデータホルダ
⑤PDFホルダ | 領収書PDFファイルを保存するホルダ
⑥Backupホルダ | インストールで古いファイルを保存するホルダ
⑦WORKホルダ | 作業用ホルダ 消されても良いファィルを保存
⑧変換DBホルダ | 変換用DBがセットされるホルダ
⑨Data保存用ホルダ |
４．ファイル設定 ・・・ 「参照」ボタンを押すと以下のファィル項目が選択出来、ファィルがセットされます。 「最適」ボタンは メインプログラムの未起動の時に操作できます。
①変換用DB名称 | 変換DBホルダのファィルを指定します。既定値：「MKpdf.mdb」
②変換用DB Log | 変換DBホルダのLogファィルを指定します。既定値：「MKpdfLog.mdb」
③Excel APP | Excel プログラムのあるホルダ プログラム初期起動で自動でセットされますが、 複数の表計算プログラムがある場合は、起動する「表計算プログラム」をセット願います。 例 Excell2003の場合、「C:\Program Files\Microsoft Office\OFFICE11\EXCEL.EXE」


バックアップ

  ◎　メニューのバックアップ*1を起動すると表示されます。
      また、プログラム終了でバックアップが起動します。
      バックアップの選択は自由です。ユーザにて対応ください。
    *1:　「メニュー」－「ファイル」－「その他」－「バックアップ」で起動できます。
  １．バックアップ　操作・・・D/B のバックアップ

  ◎バックアップファイル名の表示。
  ◎前回バッサクアップの年月日、時間を表示
      (なしの時は、ALL 0 で表示)

  ◎「いいえ」の選択でキャンセルされます。　毎回バックアップは不要ですが、
    定期的に保存願います。
  ２．バックアップ　操作・・・PDFファィルのバックアップ

  ◎バックアップPDFファイル名の表示。
  ◎前回バッサクアップの年月日、時間を表示
      (なしの時は、ALL 0 で表示)

  ◎「いいえ」の選択でキャンセルされます。
  ３．バックアップの結果表示

  バックアップファイルの名称：
  ◎D/B、PDFのバックアップの結果が表示されます。
    なお、バックアップの履歴は　No.1～ No5まで存在する。
No.1 => No.2 => No.3 => No.4 => No5 => 削除 の様にして 名前を変更している。
[ 1 ] が一番新しく、大きい番号ほど古く、[ 5 ]が一番古い。

  なお、ファィルの復旧に備え、USBデイスクなどに保存ファイルをバックアップしてください。


  操作方法


  メニュー・ツールバー　構成

  １．領収書PDF管理システムの画面構成
    ◎タイトルバー　・・　領収書PDF管理System[RyosyuPDF]　と　バージョンが表示されます。
    ◎メニューバー　・・　メニューバーをクリックして選択すると、
        操作を実行できます。
    ◎ツールバー　・・　領収書PDF管理Systemで一番多く使う操作のボタンが表示されています。
    ◎メッセージバー　・・　システムで設定されている「ホルダ」「ファイル」情報が表示されています。
  「担当者」の作業制限の為に、「パスワード」による入力画面が表示されます。
  インストール時に表示された「パスワード」を入力し「入力OK」をクリックします。
  注意事項： 異なるパスワードの場合は「入力エラー」が表示されます。
                「キャンセル」の場合、正しく動作しません。
                例えば、いろいろなボタンをクリックしても　画面表示はされません。

  最初にメンテナンスする　「会社名・事業所」　をセットします。


メニュー・ツールバー　詳細

１．領収書PDF管理システムの画面構成
メニューバー の説明
1.ファィル | １．.マスタメンテ・・・ 会社・事業所、仕入先、得意先 ２．その他・・・ システム設定、ＤＢ最適化、ＰＤＦ登録・更新日 修復、 バックアップ（ALL 年度別） ３．終 了
２．領収書・処理 | １．領収書 登録・変更 ２．発行・領収書 登録・変更 ３．領収書 検索・問合せ ４．発行・領収書書 検索・問合せ ５．領収書 集計・検索 ６．発行・領収書 集計・検索
３．データ移行処理 ・・Excel | １．仕分けﾃﾞｰﾀ ==> 領収書 ２．仕分けﾃﾞｰﾀ ==> 発行領収書
４．ウインドウ | １．現在の画面状態を保存 ２．すべての画面を閉じる ３．子画面のみ・・・ 最大化で表示、並べて表示、重ねて表示、横に並べて表示、ｱｲｺﾝの整列
５．ｵﾌﾟｼｮﾝ・設定 | １．画面表示位置・・・クリアー (左上)、 設 定、設定取込み ２．ログ出力モード ３．ログ表示
６．ヘルプ | 表示中の画面にて Ｆ１ボタンを押す
メニュー ボタン の 説 明
１．ＥＸＩＴ | プログラムを終了する。 終了する際に、バックアップ（ALL)が起動します。
２．領収書メンテ | 領収書メンテナンス画面が起動します。
３．領収 検索 | 領収書検索画面 が起動します。
４．仕分->請求 | 仕分けﾃﾞｰﾀ ==> 領収書への移行画面が表示されます。
５．発行領収書メンテ | 発行領収書メンテナンス画面が起動します。
６．発行領収書検索 | 発行領収書検索画面 が起動します。
７．仕分->発行請求 | 仕分けﾃﾞｰﾀ ==> 発行領収書への移行画面が表示されます。
８．印刷 |
その他の表示 | 以下のボタンで右ボタンクリックで表示される １．領収・検索 ボタン ・・・ 領収書・検索、 領収書・集計&検索 ２．発行領収書・検索 ボタン ・・・ 発行領収書・検索、 発行領収書・集計&検索
入力項目 の説明 ・・ メンテナンスする 会社コードを 作業の前にセットします。
１．会社'コード | 登録済の会社'コードを入力
２．会社'コード | 会社コードから名称を表示
３．会社・検索 ボタン | 登録済の会社コードからセットする時に ボタンを押し、表示一覧から選択します。


  ﾃﾞｰﾀの取込

  ◎　プログラムの起動直後、担当入力者の作業制限の為に、
      パスワードによる入力画面が表示されます。
  ◎　データ取込には、「会社コード」の入力が必要です。
■仕分データの取り込み
■領収書データ　メンテナンス
■発行領収書データ　メンテナンス
■領収書PDFファイルの取込み


  仕分データの取り込み

◎ 以下の会計ソフトからの作成された仕訳データのEXCELファィルから取込、
    領収書データを作成する。
  １．「弥生会計」仕訳 Excel-2003 形式(Ver.5以降)＊１
  ２．「MJSかんたん！青色申告」の仕訳帳　Excel(2003) ＊２
１．仕訳データの取り込み 画面構成
２．項目の概要 |
① ロード (EXCEL) | 仕訳出力したファイル「Shiwake\Shiwake*.xls」を読み取る
② 仕訳更新 | 読み取った 仕訳出力したファイル で更新する。
③ 更新会社 (必須)項目 | 更新対象の会社コードを入力する。 この入力で明細データに会社コードがセットされます。
④ 更新日付 | 日付の範囲を入力 From To で設定 日付の範囲内のデータのみ更新対象です。
⑤ 日付ワンタッチ ボタン | 更新日付をワンタッチで設定 今日 今月 年間 全期間 前年 選択した内容で自動で更新日付がセットされます。 更新日付は変更も可能です。
仕訳出力したファイルの領収書情報出力のための 仕訳帳入力 方法について

  ここからが「入力方法」のポイント
１．対象システム
  「MJSかんたん！青色申告」の仕訳帳　Excel(2003)で出力する
  「弥生会計」の仕訳 Excel-2003 形式(Ver.5以降)で出力する
２．操作方法
  １．仕訳帳入力での注意方法
    摘要欄に仕入れ先を入力します。
    方法は「S=」の次に「仕入れ先名」を記述し、最後に半角「/」をセット
    「/」の後に商品名などの備考内容をセットします。
    ◎インターネットでのネット取引の場合は半角「/NET」を記述します。
      この場合、領収書データの「発行区分」に電子の「1」がセットされます
    例えば、「　S=仕入れ先名称/商品名称/　」又は
            「　S=仕入れ先名称/商品名称/NET　」の様にセット

    売上げの時は「T=」の次に「得意先名」を記述し、最後に半角「/」をセット
    ◎インターネットでのネット取引の場合は半角「/NET」を記述します。
      (注意事項:「MJSかんたん！青色申告」の摘要欄は全角２１文字となっているので、
      項目オーバーの際はExcel出力後、摘要欄の修正を行います。)
    例えば、「　T=仕入れ先名称/商品名称/NET　」の様にセット

  ２．仕訳帳　Excelで出力する  注意：弥生会計の場合はテキストファィルとなります ＊１
    出力前に項目を追加する。
    空き項目欄に「会社CD」を追加し、その列に「会社CD」を記述する。

  ３．変更するExcelファイルを　Excel(2003)で出力
    ファイル名はホルダ「Shiwake」に
    「Shiwake」を付けます。他はわかりやすい名称を付けます。
    例えば　「ShiwakeG12021Book.xls」の様にする。

  ４．RyosyuM.exe ----領収書管理　を起動する
    1.領収書変換処理を表示する。
    2.Excelファイルを選択する。
    3.変換する「会社CD」を入力する。
    4.変換するボタンを押す。
      領収書テーブル仕訳帳データが追加されます。

  ５．領収書処理を起動する。
    検索ボタンで明細が表示されます。
    1.「pdf」ファィルの項目をクリックすると
    「pdf」ファィルが表示されます。
    2.未登録の場合は表示されませんので、
      スキャナーで領収書を取り込み、「pdf」ファィルを付けて保存します。
      なお、ホルダ名は　「\PDF\2021\B01」の場所とします。
      例えば「20210110_XXXX_00001000.pdf」の場合は以下の様になります。
      「\PDF\2021\B01」のホルダとします。
＊１：「弥生会計」仕訳 Excel-2003 形式(Ver.5以降)　について
    現在は「テキスト書き出し（エクスポート）」の出力が有効な様です。
    EXCEL での出力は MS-Office のいろいろな制限が有る様なので、使用出来ませんてした。
    弥生会計の操作ガイドの「テキスト書き出し（エクスポート）」をに記述内容　を参照ください。

    1-1.出力ポイントは、データのエクスポートの欄にある様に、「弥生インポート形式」で出力
    1-2.力ファィルはテキスト(.txt)で出力されますので出力ファィルを「EXCEL」で開きます。
    1-3.この時の「EXCEL」指定は、
      1.データファイル形式は　「カンマやタブ・・・・」を選択　次へ
      2.区切り文字の選択は　「タブ」「カンマ」をチェツクし、　次へ
      3.完了　をクリック
    1-4.「.xls」で名前を付けて出力します。
      「EXCEL」で正しく表示されたのを確認し、
      「shiwake」を付けてユニークな名称で「.xls」で出力します。
      例えば「shiwake202201.xls」の様に出力します。
      なお、「.xls」とは　Excel 2003形式です。
＊２：「MJSかんたん！青色申告」の仕訳帳　Excel(2003)について
    弥生会計　に比べて大変かんたんです。

    1-1.仕訳帳を標示し、期間を選択後、「EXCEL」出力すると、EXCELが起動します。
    1-2.「EXCEL」で正しく表示されたのを確認し、
      「shiwake」を付けてユニークな名称で「.xls」で出力します。
      なお、「.xls」とは　Excel 2003形式です。


領収書PDFファイルの取込み

  領収書データ　メンテナンス
update: Ver.2.1.0 : 発行区分=１電子の時、PDF Copyの１(４つのうち一番上)を設定すると、
                          元ファイル等１にも　PDFファイル元データがセットさ、保存ホルダにもファィルがコピーされる。

１．領収書データ メンテナンス の 画面構成 (サンプル画面はVer.0.9.0の場合)
２．項目の概要
① 処理区分 | １：登録 ２：修正 ３：削除 登録、修正、削除 を押すと、処理区分にセットされます。 終了 を押すと画面を閉じます。
② 領収年月日 |
③ 仕入先コード |
④ 領収金額 |
⑤ 明細表示 | ②～④までの内容で該当する領収書が有れば、仕入先名からの項目を表示する。
⑥ 明細更新 | 登録、または変更された項目内容で データ更新する。ただし、①の処理区分に従います。
⑦ 中止 | 中止の場合 何もせず、①処理区分に戻ります。
⑧ 会社コード | 会社コード または 事業所 を入力・・・(メイン画面の会社コード入力が表示されます。) 変更も可能です。 直接「会社コード」を入力 又は「会社検索」で入力できます。
⑨ 会社検索 | 会社の一覧が表示され、選択すると会社名がセットされる。 会社を選択後に画面を閉じます。
⑩ 仕入先検索 | 仕入先の一覧が表示され、選択すると仕入先名がセットされる。
⑪ PDFの表示 | PDFファィルの表示画面の選択。 ブラウザ指定で標準ブラウザに表示する。(画面表示は現在未サポート)
⑫ 手前に表示 | チェツクが有ると 表示画面を常に手前に表示します。
⑬ SET | PDFファイル名をセットします。・・・ 「日付＋仕入先名＋金額．PDF」
⑭ PDF表示 | セットされたPDFファイル名を表示します。 未セットの場合は表示なしのメッセージを表示
⑮ PDF表示 | 元ファイル名のPDFファイル名を表示します。 未セットの場合は表示なしのメッセージを表示
⑯ PDF COPY | Ver.2.1.0 より 改定 １． スキャナーで読み込まれたPDFファィルをセットされたPDFファイル名に変更し規定ホルダにCOPYします。 ２．ネットがら取得したPDFファィルを規定ホルダにCOPYします。かつ元ファイル名欄にPDFファイル名を表示します。 Ver.2.1.0 より 改定； 発行区分=１電子の時、PDF Copyの１(４つのうち一番上)を設定すると、 元ファイル等１にも PDFファイル元データがセットさ、保存ホルダにもファィルがコピーされる。
⑰ PDF規定ホルダ | PDFファィルを保存する規定ホルダ名が表示されています。
Ａ ～ Ａ＋ | 仕入先〒 から 税率 までは 任意な情報項目です。 ( ⑬～⑰まで、Ｂ～Ｂ＋までは除きます) 借方科目、貸方科目・・仕訳データ取込から移行したときに自動でセットされた内容が表示されます。 請求書YMD ・・ 請求書の日付をセットする 発行区分 ・・・ １桁目１：請求書 ２桁目：領収書 ０：紙 １：電子 ２：メール ８：その他 ファイル区分 ・・・ ０; pdf のみ・・・現在の仕様
Ｂ ～ Ｂ＋ | 入力項目の変更された場合の日付が表示されます。 (登録日、修正日、PDF登録日、PDF修正日、)
Ｃ 検索 | 選択項目で領収書の内容を表示します。 表示された明細の各種操作について・・・以下の画面、表を参照ください。
Ｄ 選択項目のセット | 検索された明細を選択し、この「ボタン」で 上段の項目が表示されます。
検索明細MAX件数 | 既定値は３００件 変更は可能です。次回ヘ継続されます。
３．検索内容の 画面構成
４．検索内容の概要
検索項目 | 選択項目は １．日付の範囲、 ２．仕入先名(曖昧検索可能) ３．金額、 ４．会社CD(事業所も含む) 「スペース」または「０」の場合は全項目対象・・ 日付は選択ボタンでのセットが可能、 金額はALL、大、小、根等しい から選択 会社コードは自動でメイン画面のコードが表示されますが、変更、又はスペースも可能です。
表示項目 | 日付、仕入先CD、仕入先名、金額、発行区分、ファイル区分、PDFファイル名、会社CD、会社名、概要、 登録日、修正日、PDF登録日、PDF修正日、請求書YMD
PDFファイル名 | 黒色表示： PDF登録日 Space, or ALL 0 ・・・ PDF未登録 赤色表示： PDF修正日 有り ・・・ PDF修正登録あり 青色表示： PDF修正日 なし ・・・ PDF登録済
その他の機能 | 各項目の表題のクリックで 昇順・降順で並び替え、PDFファイル名のクリックでPDFファイルを画面表示


  発行領収書データ　メンテナンス

◎　領収書データ　メンテナンス　と同様な操作方法です。
  領収書データ　メンテナンスのページを参照ください。


領収書データ メンテナンス

  領収書PDFファイルの取込み

  ◎PDFファィルの作成はパソコンによっていろいろ有ると思います。
    ここでは推奨する方法として以下に、動作環境に記述しています。
  Canon 「スキヤナー」の「Canon My Imaage Garden」で行います。

１．Canon 「スキヤナー」の「Canon My Imaage Garden」で記述
  １．「Canon My Imaage Garden」の起動画面

  「スキャナー」を選択する。
  ２．スキャナーの「スキャン設定」画面

    「ScanGear」をクリックし
    データ形式を　「PDF」　に設定
    PDF圧縮タテプを「高圧縮」　に設定
        「OK」 をクリック

  ３．スキャン　の開始

    「ドライバー」をクリックし、
    「プレビュー」をクリック、
    「出力解像度」を200dpi
    「出力サイズ」をフリーサイズ

    「サムネイル」の表示を切り替える。
    「スキャン」ボタンを押す。
  ４．PDFファィルの取込
  ５．PDFファィルの保存

    １．　「保存」ボタンをクリックする。

    ２．「データ形式」をPDF を確認し、
      「保存」をクリックする。

  ◎複数のPDFファイルを一つのPDFとする時は、
    複数複数のPDFを選択し、保存します。
  ６．PDFファィルの割付、取込

  領収書　メンテナンス　で
  「PDF Copy」ボタンをクリックし、
    「５．PDFファィルの保存」で出力したファイルを
    選択します。
  ７．PDFファィルの確認、表示

    「pdf 表示」ボタンをクリックします。
  表示画面に「PDFファイル」が表示されます。

  表示画面には
  １．ブラウザ画面
  ２．画面表示が有ります。

  パソコンのよって正しく表示される画面を選択下さい。

  画面サンプルでは PDF表示ソフトとして
  「Sdobe Systems X1」 の場合の表示です。
また、WIndows10,11では
  「Adobe Acrobat DC」で動作しています。


  領収書PDFの検索

■領収書、発行領収書　の検索・・・領収書　及び　発行領収書の検索を行えます。
■領収書、発行領収書　の　検索・集計・・・領収書　及び　発行領収書　の　検索を行い、仕入先名の集計が行えます。


領収書、PDFの検索－１

  領収書、発行領収書の検索

表示サンプルは Ver.2.1.0 のものです。
１．ボタン などの 説明
１．終了 | 画面を閉じます。また。最大明細件数を保存します。
２．印 刷 | 画面のイメージを印刷する画面を表示し、印刷も可能です。 また、以下の項目で表示、出力が可能です。 １．EXCELを表示 ２．画面表示・・Print ３．クリップボードに出力
３．検 索 | 「2.検索内容」の選択、入力項目を基にして、検索します。 明細最大行数まで表示します。 明細数が明細最大行数を超えた場合はメッセージにて注意表示します。
４．選択項目セット | 選択した明細行の内容を検索項目のうち、「入力項目」にセットします。
２．検索内容の概要
検索項目 | 選択項目は １．日付の範囲、 ２．仕入先名(曖昧検索可能) ３．金額、 ４．会社CD(事業所も含む) 「スペース」または「０」の場合は全項目対象・・ 日付は選択ボタンでのセットが可能、 金額はALL、大、小、根等しい から選択
表示項目 | 日付、仕入先CD、仕入先名、金額、発行区分、ファイル区分、PDFファイル名、会社CD、会社名、概要、 登録日、修正日、PDF登録日、PDF修正日、請求書YMD など
その他の機能 | 各項目の表題のクリックで 昇順・降順で並び替え、PDFファイル名のクリックでPDFファイルを画面表示
３．その他 項目 の 説明
１．手前に表示 | チェツクが有ると 表示画面を常に手前に表示します。
２．フォントサイズ | 明細一覧表の文字サイズを変更できます。
３．明細最大行数 | 検索表示時の 明細の最大表示件数
４．PDF表示画面 | PDFファィルの表示画面の選択。 １．ブラウザ表示 ・・・ ブラウザ指定で標準ブラウザに表示する。 ２．画面表示 ・・・ PDF表示ツールがインストールされている時は 専用画面表示となります。


領収書、発行領収書 の 集計・検索

  領収書、発行領収書　の　検索・集計

１．ボタンの説明
１．終了 | 画面を閉じます。また。最大明細件数を保存します。
２．印 刷 | 画面のイメージを印刷する画面を表示し、印刷も可能です。 また、以下の項目で表示、出力が可能です。 １．EXCELを表示 ２．画面表示・・Print ３．クリップボードに出力
３．検 索 | 選択項目で検索します。 明細最大行数まで表示します。 明細数が明細最大行数を超えた場合はメッセージにて注意表示します。
４．集 計 | 表示項目で並び替え後で、仕入先名毎で集計します。 集計ボタンを押すと金額の「小計」「明細合計」を表示します。
５．選択SET | 選択したした明細行データ を 検索項目にセットします。
２．検索内容の概要
検索項目 | 選択項目は １．日付の範囲、 ２．仕入先名(曖昧検索可能) ３．領収金額、 ４．会社CD(事業所も含む) 「スペース」または「０」の場合は全項目対象・・ 日付は選択ボタンでのセットが可能、 金額はALL、大、小、根等しい から選択
表示項目 | 日付、仕入先CD、仕入先名、金額、発行区分、ファイル区分、PDFファイル名、会社CD、会社名、概要、 登録日、修正日、PDF登録日、PDF修正日、請求書YMD など
その他の機能 | 各項目の表題のクリックで 昇順・降順で並び替え、PDFファイル名のクリックでPDFファイルを画面表示
３．その他 項目 の 説明
１．手前に表示 | チェツクが有ると 表示画面を常に手前に表示します。
２．フォントサイズ | 明細一覧表の文字サイズを変更できます。
３．明細最大行数 | 検索表示時の 明細の最大表示件数
４．PDF表示画面 | PDFファィルの表示画面の選択。 １．ブラウザ表示 ・・・ ブラウザ指定で標準ブラウザに表示する。 ２．画面表示 ・・・ PDF表示ツールがインストールされている時は 専用画面表示となります。


  修正ログ表示


  ログ表示

  １．ボタン などの　説明

  ボタンの操作に関して、「領収書、発行領収書の検索」を参照ください。


  マスタメンテナンス

   Ver.２にて「検索ボタン」を押すと「明細一覧」に表示されます。
■会社Mメンテナンス
■仕入先Mメンテナンス
■得意先Mメンテナンス


  会社Mメンテナンス

   Ver.２にて「検索ボタン」を押すと「明細一覧」に表示されます。

１．システム設定 の 画面構成
初期 表示画面です。 ＊：必須入力項目 処理選択の後に表示されるボタン
２．操作ボタンの内容
① 終了 | 画面を閉じ、プログラム終了します。
② 登録 | 会社コードの入力になります。 コードがすでに存在する場合は登録済メッゼジが有ります。 また、「実行」「取消」ボタンが表示されます。(以下同様)
③ 修正 | 会社コードの入力になります。
④ 削除 |
⑤ 参照 | 「会社コード」の時に「実行」を押すと、明細が表示されます。 また、「会社コード」なしで「実行」を押すと、最初のデータが表示されます。 ボタンは ⑥始 ～終 までが表示されます。
⑥ 始 ～終 まで | 「始」：最初のキー項目の表示 「＜」：一つ前のキーが表示 「＜」：一つ前のキーが表示 「終」：最後のキー項目の表示
⑦ 実行 | 「実行」ボタンで、入力内容が登録され、会社コード入力へ戻ります。
⑧ 取消し | 「取消」で、入力内容が取り消され、会社コード入力へ戻ります。 また、「会社コード」未入力で押された場合、は「処理選択」に戻ります。
３．各項目 入力 |
①会社コード 半角４文字 | 「登録」の時は、コードがすでに存在する場合は登録済メッゼジが有ります。 「修正」「削除」の時は、登録済として内容が表示されます。 コードがすでに存在しない場合は、「該当データが有りません」を表示。
②フリガナ | フリガナ を入力します 必須 入力 願います。
③会社名 | 会社名 を入力します 必須 入力 願います。
④その他 の項目 | 部署～ファクシミリ までは自由記載


  仕入先Mメンテナンス

   Ver.２にて「検索ボタン」を押すと「明細一覧」に表示されます。

１．システム設定 の 画面構成
初期 表示画面です。 ＊：必須入力項目 処理選択の後に表示されるボタン
２．操作ボタンの内容
① 終了 | 画面を閉じ、プログラム終了します。
② 登録 | 仕入先コードの入力になります。 コードがすでに存在する場合は登録済メッゼジが有ります。 また、「実行」「取消」ボタンが表示されます。(以下同様)
③ 修正 | 仕入先コードの入力になります。
④ 削除 |
⑤ 参照 | 「仕入先コード」の時に「実行」を押すと、明細が表示されます。 また、「仕入先コード」なしで「実行」を押すと、最初のデータが表示されます。 ボタンは ⑥始 ～終 までが表示されます。
⑥ 始 ～終 まで | 「始」：最初のキー項目の表示 「＜」：一つ前のキーが表示 「＜」：一つ前のキーが表示 「終」：最後のキー項目の表示
⑦ 実行 | 「実行」ボタンで、入力内容が登録され、仕入先コード入力へ戻ります。
⑧ 取消し | 「取消」で、入力内容が取り消され、仕入先コード入力へ戻ります。 また、「仕入先コード」未入力で押された場合、は「処理選択」に戻ります。
３．各項目 入力 |
①仕入先コード 数字４文字 | 「登録」の時は、コードがすでに存在する場合は登録済メッゼジが有ります。 「修正」「削除」の時は、登録済として内容が表示されます。 コードがすでに存在しない場合は、「該当データが有りません」を表示。
②フリガナ | フリガナ を入力します 必須 入力 願います。
③仕入先名 | 仕入先名 を入力します 必須 入力 願います。
④その他 の項目 | 部署～ホームページ までは自由記載


  得意先Mメンテナンス

   Ver.２にて「検索ボタン」を押すと「明細一覧」に表示されます。

１．システム設定 の 画面構成
初期 表示画面です。 ＊：必須入力項目 処理選択の後に表示されるボタン
２．操作ボタンの内容
① 終了 | 画面を閉じ、プログラム終了します。
② 登録 | 得意先コードの入力になります。 コードがすでに存在する場合は登録済メッゼジが有ります。 また、「実行」「取消」ボタンが表示されます。(以下同様)
③ 修正 | 得意先コードの入力になります。
④ 削除 |
⑤ 参照 | 「得意先コード」の時に「実行」を押すと、明細が表示されます。 また、「得意先コード」なしで「実行」を押すと、最初のデータが表示されます。 ボタンは ⑥始 ～終 までが表示されます。
⑥ 始 ～終 まで | 「始」：最初のキー項目の表示 「＜」：一つ前のキーが表示 「＜」：一つ前のキーが表示 「終」：最後のキー項目の表示
⑦ 実行 | 「実行」ボタンで、入力内容が登録され、得意先コード入力へ戻ります。
⑧ 取消し | 「取消」で、入力内容が取り消され、得意先コード入力へ戻ります。 また、「得意先コード」未入力で押された場合、は「処理選択」に戻ります。
３．各項目 入力 |
①得意先コード 数字４文字 | 「登録」の時は、コードがすでに存在する場合は登録済メッゼジが有ります。 「修正」「削除」の時は、登録済として内容が表示されます。 コードがすでに存在しない場合は、「該当データが有りません」を表示。
②フリガナ | フリガナ を入力します 必須 入力 願います。
③得意先名 | 得意先名 を入力します 必須 入力 願います。
④その他 の項目 | 部署～Fax までは自由記載


  ご使用上の注意事項とトラブルＱ＆Ａ

  1. Ｑ１．インストールの後、最初に行うことは？
        サンプル用の会社、事業所が一つ登録してあります。
  2. Ｑ２．
  3. Ｑ３．
  4. Ｑ４．
  5. Ｑ５．
  6. Ｑ６．
  7. Ｑ７．
  8. Ｑ８．
  9. Ｑ９．
  10. Ｑ１０．


  改定履歴

  ●　Ver.2.1.0 改訂日付 2022.08.22
        領収書PDF管理システム　[RyosyuPDF] V2　の改定　及び　不具合改修
    不具合改修
      １．各検索画面の明細件数について
          設定の明細件数を超えて　明細が有る場合、
          エラーが発生し、プログラム終了していた。
          この場合メッセージを表示しました。
          また、設定の明細件数を変更すると　設定件数まで表示されます。
      ２．MS-office 2010 以降のインストールパソコンでデータ更新ときに「3164エラー」が発生。
          テーブんの項目タイプを変更しました。<== Ver upではDBが変更されます。
    改定内容
      １．メインプログラムのボタンメニューの変更
          詳しくは、メニュー・ツールバー　構成　を参照願います。
            例えば、「領収・検索」の右ボタンクリックで
          ２つの画面起動が選択できます。
      ２．修正ログ表示の画面　の設定明細件数　について
          他の検索画面と同じ件数を表示していましたが、
          専用の件数を表示とし、規定値は1000件としました。
          また、変更件数は以後　継続されます。
      ３．ヘルプの記述追加
          説明不足の内容の記述を修正、追加しました。
        多少記述不足な部分がありますが、今後、少しづつ改定する予定です。
  ●　Ver.2.0.0 改訂日付 2022.05.20
        領収書PDF管理システム　[RyosyuPDF] V2　をリリース
    機能一覧
      １．集計・検索　画面を追加・・・　項目の並び替え後で、「集計」ボタンで集計が行える
      2.　マスタメンテナンス画面に「検索ボタン」「明細一覧」を追加。
          「検索ボタン」を押すと「明細一覧」に表示されます。

  ●　Ver.1.0.0 改訂日付 2022.01.01
        領収書PDF管理システム　[RyosyuPDF]　をリリース
    機能一覧
      １．領収書pdfを保存する。
        ａ.pdfを検索する形式で出力、
        ｂ.ネットでの送付されたそのままのPDF形式で保存
      ２．領収書pdfを検索する。
          「領収書の作成日付」「領収書の仕入先名」「領収書の金額作成日付」で検索
      ３．仕訳帳データからデータを作成するツールを提供
        ａ.「MJSかんたん！青色申告」の仕訳帳データ－Excel(2003)から自動作成が可能。
        ｂ.「弥生会計」のエクスホート仕訳帳データ－Excel(2003)から自動作成が可能。
      ４．保存された領収書pdfをHTMLブラウザ、専用画面で表示する。
         (ただし、PDF表示のソフトが必要です。)
      ５．PDF変更した場合のログデータを出力します。
        また、表示するプログラムを提供。
      ６．データ入力担当者を限定する方法として、
        プログラム起動時に、パスワード入力とします。
    インストールの提供
      ．バージョンは　Ver.1.0.0 とする。
      ．ブログラムの種類
        「RyosyuM.exe」「RpdfSYS.exe」「RpdfSai.exe」
        マスターメンテナンス－「RTOKUIM.exe」「RSHIRM.exe」「RKAISM.exe」
        PDF変更ログ表示－「RLogDsp.exe」


  サポートなどのご案内